summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAman2020-06-09 14:36:30 +0530
committerAman2020-06-09 14:36:30 +0530
commitf77c85e90fcb71a7c8a14db3add4acc6a63e3523 (patch)
treea0820ccba340dc17f3380279328d81e7c9e155b6 /PKGBUILD
downloadaur-f77c85e90fcb71a7c8a14db3add4acc6a63e3523.tar.gz
initial release version 0.0.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63cf2c8d3ea9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Aman Sinha
+
+pkgname=mongodb-shell
+pkgver=0.0.5
+pkgrel=1
+pkgdesc='The MongoDB Shell is a fully functional JavaScript environment for interacting with MongoDB deployments.'
+url='https://www.mongodb.com/'
+license=('custom')
+depends=('mongodb-bin')
+provides=("mongosh=$pkgver")
+arch=('x86_64')
+source=("https://downloads.mongodb.com/compass/mongosh-$pkgver-linux.tgz")
+sha256sums=('d1312f133909abddb3b507e8445199770f6c454c1e809abe45655fc0fe1b863f')
+options=(!strip)
+package() {
+ cd $srcdir
+ install -Dm755 mongosh $pkgdir/usr/bin/mongosh
+}