summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2022-10-13 13:48:04 -0300
committerRafael Fontenelle2022-10-13 13:48:04 -0300
commit09532e63f1eafe16bd778004e75c2c9f6dc94841 (patch)
tree6079d7f3c6c72dbefa304f99744f623fe2bd4fb9 /PKGBUILD
parent252cd1e8b05ef61c2bd572025d153f2293b655a2 (diff)
downloadaur-09532e63f1eafe16bd778004e75c2c9f6dc94841.tar.gz
Update to 4.2.23
Remove conf and service
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 36 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb0faee0ff57..0089795a0df6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
#Maintainer: Rafael Fontenelle <rafaelff at gnome dot org>
pkgname="mongodb42-bin"
-pkgver="4.2.22"
+pkgver="4.2.23"
_basever="4.2"
_basedist="bionic"
pkgrel="1"
@@ -18,8 +18,6 @@ backup=("etc/mongodb.conf")
_repo_url=https://repo.mongodb.org/apt/ubuntu/dists/${_basedist}/mongodb-org/${_basever}/multiverse
source=(
- "mongodb.conf"
- "mongodb.service"
"mongodb.sysusers"
"mongodb.tmpfiles"
"LICENSE"
@@ -36,32 +34,50 @@ noextract=(
mongodb-org-shell_${pkgver}_${CARCH}.deb
mongodb-org-server_${pkgver}_${CARCH}.deb
mongodb-org-mongos_${pkgver}_${CARCH}.deb)
-sha256sums=('16db77050441afb964b1899f82466d53a0677c9c4802cd98b967d3cc2efe094f'
- 'de4f6770c45bc5418883659c479783c0184a6057df1c405a7933637984f82f0a'
- '47b884569102f7c79017ee78ef2e98204a25aa834c0ee7d5d62c270ab05d4e2b'
+sha256sums=('47b884569102f7c79017ee78ef2e98204a25aa834c0ee7d5d62c270ab05d4e2b'
'51ee1e1f71598aad919db79a195778e6cb6cfce48267565e88a401ebc64497ac'
'09d99ca61eb07873d5334077acba22c33e7f7d0a9fa08c92734e0ac8430d6e27')
-sha256sums_x86_64=('cb88b2705b614ffbdeca741ebdc12ee0430baa76d025c396fcf5c207da4ba82e'
- '83a172fb144da9c8a9d38aae8938316429595e1e4b86cf7d3aa10000d83d188a'
- 'c198be9eb24b41a2b6e79525402799faa659a9c074177297b970ae521e9b66d9')
-sha256sums_aarch64=('a5c78a4ed4a5eef9208716e8499f6fe4da9f01a9a98975a9f6d111f2e202ce53'
- '54d789c5291fccb9fe3dc088cf36c70e990d2d19b4a1efaf6a417d6134b96584'
- 'dafe5e3cd1ffac77cee3ee9c352996b0f9d3c3abe69ecc5e02a255bc5dcedaec')
+sha256sums_x86_64=('6777caef66f2030e5e1a8e2031b379fb793e9353fd34cf889eb5980294cdcdb9'
+ 'eadf58310ec4bb8bcdfd27f04fa2957d72b903bce37cac7d9db13b8cbeb51555'
+ '869076990f4b9e6288283e82ce23caeca5cd86232acfc1a3fd8adb66d00cba93')
+sha256sums_aarch64=('22a20a46e2f5f4d59266d36f90eb422a3e2c2e36d7a61cd38348d5e36406da6c'
+ '73649e882059cb844cf30054f454e33dceee094768ff0267488073cd9a32bcbf'
+ '93cd883b0f477f57debeedc31113934687b58ebea5609cd515b293ea20316ee2')
prepare() {
mkdir -p output
bsdtar -O -xf mongodb-org-shell_${pkgver}_${CARCH}.deb data.tar.xz | bsdtar -C output -xJf - #mongo extracted
bsdtar -O -xf mongodb-org-server_${pkgver}_${CARCH}.deb data.tar.xz | bsdtar -C output -xJf - #server extracted
bsdtar -O -xf mongodb-org-mongos_${pkgver}_${CARCH}.deb data.tar.xz | bsdtar -C output -xJf - #mongos extracted
+
+ # Keep historical Arch dbPath
+ sed -i 's|dbPath: /var/lib/mongo$|dbPath: /var/lib/mongodb|' output/etc/mongod.conf
+
+ # Keep historical Arch conf file name
+ sed -i 's|/etc/mongod.conf|/etc/mongodb.conf|' output/lib/systemd/system/mongod.service
+
+ # Keep historical Arch user name (no need for separate daemon group name)
+ sed -i 's/User=mongod$/User=mongodb/' output/lib/systemd/system/mongod.service
+ sed -i 's/Group=mongod$/Group=mongodb/' output/lib/systemd/system/mongod.service
+
+ # Avoid legacy PID filepath
+ sed -i 's|/var/run/|/var/|' output/lib/systemd/system/mongod.service
+
+ # Remove sysconfig file, used by upstream's init.d script not used on Arch
+ sed -i '/^EnvironmentFile=/d' output/lib/systemd/system/mongod.service
+
+ # Make systemd wait as long as it takes for MongoDB to start
+ # If MongoDB needs a long time to start, prevent systemd from restarting it every 90 seconds
+ # See: https://jira.mongodb.org/browse/SERVER-38086
+ sed -i 's/\[Service]/[Service]\nTimeoutStartSec=infinity/' output/lib/systemd/system/mongod.service
}
package() {
- mkdir -p "$pkgdir/usr/share/man"
- cp -r "output/usr/bin" "$pkgdir/usr/"
- cp -r "output/usr/share/man/man1" "$pkgdir/usr/share/man/"
- install -Dm644 "mongodb.conf" "$pkgdir/etc/mongodb.conf"
- install -Dm644 "mongodb.service" "$pkgdir/usr/lib/systemd/system/mongodb.service"
- install -Dm644 "mongodb.sysusers" "$pkgdir/usr/lib/sysusers.d/mongodb.conf"
- install -Dm644 "mongodb.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/mongodb.conf"
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 output/etc/mongod.conf "$pkgdir/etc/mongodb.conf"
+ install -Dm644 output/lib/systemd/system/mongod.service "$pkgdir/usr/lib/systemd/system/mongodb.service"
+ install -Dm755 output/usr/bin/* -t "$pkgdir/usr/bin"
+ install -Dm644 output/usr/share/man/man1/* -t "$pkgdir/usr/share/man/man1"
+ install -Dm644 mongodb.sysusers "$pkgdir/usr/lib/sysusers.d/mongodb.conf"
+ install -Dm644 mongodb.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/mongodb.conf"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}