summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlphaJack2020-08-12 14:39:16 +0200
committerAlphaJack2020-08-12 14:39:16 +0200
commit631edee3f411e130b4cf60f217a34dab9a45b902 (patch)
tree12426403873462c38e4cea75e589f528d628e389 /PKGBUILD
parent2bce0bee7ae26f03d5d3129c49ad08d3529648e5 (diff)
downloadaur-631edee3f411e130b4cf60f217a34dab9a45b902.tar.gz
Tidied PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc3738dffdaf..4581dd1870f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,26 @@
pkgname=monica-git
_pkgname=monica
-pkgver=v2.18.0.r145.g836e2ea5b
+pkgver=v2.18.0.r159.g0db37fdd7
pkgrel=1
-pkgdesc='Personal CRM. Remember everything about your friends, family and business relationships'
-arch=('any')
-url='https://www.monicahq.com'
-license=('AGPL-3.0')
-depends=('php>=7.2')
-makedepends=('composer')
-optdepends=('mariadb: database'
- 'mysql: database'
- 'apache: web server'
- 'nginx: web server')
-source=('git+https://github.com/monicahq/monica.git')
-sha512sums=('SKIP')
+pkgdesc="Personal CRM. Remember everything about your friends, family and business relationships"
+arch=("any")
+url="https://www.monicahq.com/"
+license=("AGPL-3.0")
+depends=("php>=7.2")
+makedepends=("composer")
+optdepends=("mariadb: database"
+ "mysql: database"
+ "apache: web server"
+ "nginx: web server"
+ "redis: cache and session driver")
+source=("git+https://github.com/monicahq/monica.git")
+md5sums=("SKIP")
backup=("etc/webapps/$_pkgname/config.env")
pkgver(){
cd "$_pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed "s/\([^-]*-g\)/r\1/;s/-/./g"
}
package(){