summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrás Wacha2019-05-30 10:10:56 +0200
committerAndrás Wacha2019-05-30 10:10:56 +0200
commitcf7e24429782c455c1442e4c74c6bf325e7ab495 (patch)
tree9a3aa9321cba5eb32ac3bc6195784a1448dad163 /PKGBUILD
parentf90d950d99cfedcd2683dcb38448bdaf03f15ff7 (diff)
downloadaur-monitoring-plugins-qnap.tar.gz
Added patch for authentication
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8fde249c97f..052b6df80b65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,20 @@
# Maintainer: András Wacha <awacha@gmail.com>
pkgname=monitoring-plugins-qnap
pkgver=1.40
-pkgrel=1
+pkgrel=2
pkgdesc="This plugin sends SNMP queries to a QNAP NAS and checks the cpu, HDD status, system temperature, HDD temperature"
arch=( x86_64 )
url="https://exchange.nagios.org/directory/Plugins/Hardware/Storage-Systems/Others/check_qnap"
license=('GPL')
depends=()
-source=("check_qnap.sh::https://exchange.nagios.org/components/com_mtree/attachment.php?link_id=5931&cf_id=29")
-md5sums=('b0762dc0ac03cbe43c75e3a367115aa7')
+source=("check_qnap.sh::https://exchange.nagios.org/components/com_mtree/attachment.php?link_id=5931&cf_id=29"
+ "authentication.patch")
+md5sums=('b0762dc0ac03cbe43c75e3a367115aa7'
+ 'SKIP')
+
+prepare() {
+ patch -f ../check_qnap.sh < authentication.patch
+}
package() {
mkdir -p $pkgdir/usr/lib/monitoring-plugins/