summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormrAppleXZ2016-12-12 22:46:13 +0500
committermrAppleXZ2016-12-12 22:46:13 +0500
commit3143d50ed23e66854e58fa4e1c85afbabd281bb9 (patch)
treed7af67f97e4ff8e0900a041e2413aa26d4d81a90 /PKGBUILD
downloadaur-3143d50ed23e66854e58fa4e1c85afbabd281bb9.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD64
1 files changed, 64 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a8db7ae9cd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+pkgname=mono-alpha
+_pkgname=mono
+pkgver=4.8.0
+pkgrel=1
+pkgdesc="Free implementation of the .NET platform including runtime and compiler. Alpha version."
+arch=('i686' 'x86_64')
+license=('GPL' 'LGPL2.1' 'MPL' 'BSD' 'custom=MITX11' 'custom=MSPL')
+url="http://www.mono-project.com/"
+depends=('zlib' 'libgdiplus' 'sh' 'python' 'ca-certificates' 'mono')
+makedepends=('git')
+options=('!makeflags')
+provides=('monodoc' 'mono')
+conflicts=('monodoc' 'mono')
+source=('git://github.com/mono/mono.git' 'mono.binfmt.d')
+md5sums=('SKIP' 'b9ef8a65fea497acf176cca16c1e2402')
+
+build() {
+ cd "${srcdir}"/"${_pkgname}"
+
+ # Build mono
+ ./autogen.sh --prefix=/usr \
+ --sysconfdir=/etc \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --disable-quiet-build \
+ --with-mcs-docs=yes
+ make
+
+ # Build jay
+ cd "${srcdir}"/"${_pkgname}"/mcs/jay
+ make
+}
+
+package() {
+ cd "${srcdir}"/"${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+
+ # Install jay
+ pushd "${srcdir}"/"${_pkgname}"/mcs/jay
+ make DESTDIR="${pkgdir}" \
+ prefix=/usr \
+ INSTALL=../../install-sh \
+ install
+ popd
+
+ # Install binfmt conf file and pathes
+ install \
+ -m644 \
+ -D "${srcdir}"/mono.binfmt.d "${pkgdir}"/usr/lib/binfmt.d/mono.conf
+
+ # Install license
+ mkdir \
+ -p "${pkgdir}"/usr/share/licenses/"${_pkgname}"
+
+ install \
+ -m644 \
+ -D "LICENSE" "${pkgdir}"/usr/share/licenses/"${_pkgname}"/
+
+ # Fix .pc file to be able to request mono on what it depends,
+ # fixes #go-oo build
+ sed \
+ -i \
+ -e "s:#Requires:Requires:" "${pkgdir}"/usr/lib/pkgconfig/mono.pc
+} \ No newline at end of file