summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArnaud Berthomier2020-11-11 10:02:45 -0600
committerArnaud Berthomier2020-11-11 10:02:45 -0600
commit1d6c49ecf4d72a0fb987b8a140fecfc966f6e3d6 (patch)
treef25f16e0983bd03880a81c0dc13c3b3501d97ea1 /PKGBUILD
parent17b3ef36b487412b11c78faccc5744923e86a6b2 (diff)
downloadaur-1d6c49ecf4d72a0fb987b8a140fecfc966f6e3d6.tar.gz
monocypher's Makefile isn't so bad
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65824c7a6f0d..30f23456f1d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=monocypher
_pkgname=monocypher
pkgver=3.1.1
-pkgrel=2
+pkgrel=3
pkgdesc="Monocypher is an easy to use crypto library inspired by libsodium and TweetNaCl"
arch=('i686' 'x86_64')
url="https://monocypher.org/"
@@ -15,16 +15,9 @@ sha512sums=('9c202ffe74eac1f2a7f21b8e195d981c21c5792b788315dea168cf40f1ee83cb787
package() {
cd "$_pkgname-$pkgver"
- install -d -m 755 "$pkgdir/usr/include/$pkgname"
- install -m 644 src/monocypher.c "$pkgdir/usr/include/$pkgname/monocypher.c"
- install -m 644 src/monocypher.h "$pkgdir/usr/include/$pkgname/monocypher.h"
- install -m 644 src/optional/monocypher-ed25519.h "$pkgdir/usr/include/$pkgname/monocypher-ed25519.h"
- install -m 644 src/optional/monocypher-ed25519.c "$pkgdir/usr/include/$pkgname/monocypher-ed25519.c"
+ make install USE_ED25519=true PREFIX=usr DESTDIR="$pkgdir"
+ make install-doc USE_ED25519=true PREFIX=usr DESTDIR="$pkgdir"
+
install -d -m 755 "$pkgdir/usr/share/licenses/$pkgname"
install -m 644 LICENCE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -d -m 755 "$pkgdir/usr/share/man/man3"
- install -m 644 doc/man/man3/*.3monocypher "$pkgdir/usr/share/man/man3/"
- install -m 644 doc/man/man3/optional/* "$pkgdir/usr/share/man/man3/"
- install -d -m 755 "$pkgdir/usr/lib/pkgconfig"
- install -m 644 monocypher.pc "$pkgdir/usr/lib/pkgconfig/"
}