summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMantas Mikulėnas2022-02-22 10:41:20 +0200
committerMantas Mikulėnas2022-02-22 10:44:57 +0200
commitb6dbb85e5c3fe94b3e1ffb014cf30cbea7a783b6 (patch)
tree4812a9b06115f96ba8623b2a724a491c69e9a286 /PKGBUILD
parent4071b9e8ac2679ce206a943d0dcac9de7acff33e (diff)
downloadaur-b6dbb85e5c3fe94b3e1ffb014cf30cbea7a783b6.tar.gz
use 'find -exec'
I think we can assume GNU findutils, as makepkg itself relies on it.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6cb2cac116e..4c3ad2b5b0f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,13 +33,14 @@ prepare() {
patch -Np1 < "$srcdir/$_f"
fi
done
- echo "Replacing single-character macros"
- find . \( -name '*.cc' -o -name '*.hh' \) -type f -print0 | \
- xargs -0r sed -i -E '
-s,\<E( *\(),ERROR\1,g
-s,\<L( *\(),LOG\1,g
-s,\<P( *\(),PROGRESS\1,g
-s,\<W( *\(),WARNING\1,g'
+ echo "Replacing single-character macros conflicting with Boost"
+ find . \( -name '*.cc' -o -name '*.hh' \) -type f -exec \
+ sed -i -E '
+ s,\<E( *\(),ERROR\1,g
+ s,\<L( *\(),LOG\1,g
+ s,\<P( *\(),PROGRESS\1,g
+ s,\<W( *\(),WARNING\1,g
+ ' {} +
echo "Bootstrapping autoconf"
aclocal
autoreconf --install