summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQuentin Bourgeois2017-09-22 23:49:35 +0000
committerQuentin Bourgeois2017-09-22 23:49:35 +0000
commit22712c526b2fd35441e66114ae6f25557e949101 (patch)
tree27aad86dd95b993767b831c8606fddfc06a8531a /PKGBUILD
parent68b929ec70db57c4129e15fed568efd9802955a1 (diff)
downloadaur-22712c526b2fd35441e66114ae6f25557e949101.tar.gz
upgpkg: moolticute-git 0.9.8.r2.g2d985db-1
Also prepare to run moolticuted as unpriv user.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b4cd34b95d0..8595a9609307 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=moolticute-git
_pkgname="${pkgname%-git}"
-pkgver=0.6.2.r7.g42caf55
+pkgver=0.9.8.r2.g2d985db
pkgrel=1
pkgdesc="Easy companion for Mooltipass device"
arch=('x86_64' 'i686')
@@ -13,11 +13,15 @@ conflicts=("${_pkgname}")
depends=('libusb'
'mooltipass-udev'
'qt5-base'
- 'qt5-websockets')
+ 'qt5-websockets'
+ 'hicolor-icon-theme')
makedepends=('git'
- 'make')
-source=("git+${url}.git")
-sha256sums=('SKIP')
+ 'make'
+ 'qt5-tools')
+source=("git+${url}.git"
+ 'moolticute.sysusers')
+sha256sums=('SKIP'
+ 'a0cb3d71b107359efc6807b0b728a1abc4c9c3a2d908db63cf9d59f0c659022c')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -29,6 +33,8 @@ prepare() {
cd "${srcdir}/${_pkgname}"
sed -i "s/#define APP_VERSION \"git\"/#define APP_VERSION \"git-${pkgver}\"/" ./src/version.h
+ # sed -i 's/#User=nobody/User=moolticute/' ./systemd/moolticuted.service
+ # sed -i 's/#Group=plugdev/Group=moolticute/' ./systemd/moolticuted.service
}
build() {
@@ -49,4 +55,6 @@ package() {
cd "${srcdir}/${_pkgname}/build/"
make INSTALL_ROOT="${pkgdir}/" install
+
+ # install -Dm644 ../../moolticute.sysusers "${pkgdir}/usr/lib/sysusers.d/moolticute.conf"
}