summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit98f574412f865c4ec31a917fb17b81d9288e20d3 (patch)
tree5524b3e41c4bf0c4ae48b883a9739c4ac9fb5f14 /PKGBUILD
downloadaur-98f574412f865c4ec31a917fb17b81d9288e20d3.tar.gz
Initial PKGBUILD status as of 28.11.2014
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6fa01b877b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Dale Blount <dale@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=moon-buggy
+pkgver=1.0.51
+pkgrel=1
+pkgdesc="Moon Buggy is a simple game for the text mode"
+arch=('i686' 'x86_64')
+url="http://seehuhn.de/comp/moon-buggy"
+license=('GPL2')
+depends=('ncurses')
+options=('!emptydirs')
+install=$pkgname.install
+source=(http://seehuhn.de/data/$pkgname-$pkgver.tar.gz Makefile.in.patch)
+md5sums=('bfe23ef5cfa838ac261eee34ea5322f3'
+ '8c8cb8a25e12f574243778dac8e376a1')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+ patch -Np0 -i ${srcdir}/Makefile.in.patch
+
+ ./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info
+ make
+}
+
+package() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+ make DESTDIR=${pkgdir} install
+
+ rm ${pkgdir}/usr/share/info/dir
+}