summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobert Hamblin2022-06-20 17:48:07 -0700
committerRobert Hamblin2022-06-20 17:48:07 -0700
commitd4bc2d8888d0241922c790954cd957d42c7b2ff0 (patch)
tree516abd1f3d1ab10ea7db77e818597426b3cff694 /PKGBUILD
parent625d0913c1a56c2ecfebd2f83f5f2cd54904487f (diff)
downloadaur-d4bc2d8888d0241922c790954cd957d42c7b2ff0.tar.gz
update moon buggy to support aarch64 architectures
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c9e4f4c3e0f5..6330052ea0c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
-# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Maintainer: Robert Hamblin <hamblingreen@hotmail.com>
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
# Contributor: Dale Blount <dale@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=moon-buggy
pkgver=1.0.51
-pkgrel=1
+pkgrel=2
pkgdesc="Moon Buggy is a simple game for the text mode"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'aarch64')
url="http://seehuhn.de/comp/moon-buggy"
license=('GPL2')
depends=('ncurses')
options=('!emptydirs')
install=$pkgname.install
-source=(http://seehuhn.de/data/$pkgname-$pkgver.tar.gz Makefile.in.patch)
-md5sums=('bfe23ef5cfa838ac261eee34ea5322f3'
- '8c8cb8a25e12f574243778dac8e376a1')
+source=("http://seehuhn.de/data/$pkgname-$pkgver.tar.gz"
+ "Makefile.in.patch"
+ "config.patch")
+sha256sums=('352dc16ccae4c66f1e87ab071e6a4ebeb94ff4e4f744ce1b12a769d02fe5d23f'
+ '985df74c531400d3cba8ef3a8bc3c2fcfcc53efb42f1430c04b1a971108ca73c'
+ '6f8e82c566aafc5bf0ddf4ab4ea3381fa723278bc1744bc6923bcf9cd03d4283')
prepare() {
cd "${srcdir}"/$pkgname-$pkgver
patch -Np0 -i ${srcdir}/Makefile.in.patch
+ patch --strip=1 < ${srcdir}/config.patch
}
build() {