summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2023-03-16 16:09:58 +0300
committerCaleb Maclennan2023-03-16 16:09:58 +0300
commit335c88cf90a3858af11d7a783ad8355876cf6cc3 (patch)
tree56904983ae68d3bc1dad33f18dfa72b180fe1647 /PKGBUILD
parent7c67194b68477fdebd5bc97cd223889c99e1de9c (diff)
downloadaur-335c88cf90a3858af11d7a783ad8355876cf6cc3.tar.gz
upgpkg: moonray-git 1.0.0.0.r0.g9b629e0-1
upstream release upgpkg: moonray 1.0.0.0-1 upstream release Initialize submodules in prepare
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c71974fd410a..f21bab9904e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,8 @@ depends=(lua
makedepends=(boost
cmake
git
- usd)
+ #usd # in AUR but doesn’t build
+ )
source=("$_pkgname::git+$_url/$_pkgname#tag=v$pkgver"
"$_pkgname+arras+arras4_core::git+$_url/arras4_core.git#commit=2157c5103156f652b0966f23e32b97597b7ff16f"
"$_pkgname+arras+arras_render::git+$_url/arras_render.git#commit=729c4039a72e2dacb810c17fd529eaa0308435f6"
@@ -59,6 +60,17 @@ sha256sums=('SKIP'
prepare() {
cd "$_pkgname"
+ git submodule init
+ for s in ${source[@]%%::*}; do
+ case "$s" in
+ $_pkgname+*)
+ local module=${s#$_pkgname+}
+ local path=${module//+//}
+ git config submodule.$path.url "$srcdir/$s"
+ ;;
+ esac
+ done
+ git -c protocol.file.allow=always submodule update
}
build() {