summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSean Haugh2018-02-03 17:31:25 -0600
committerSean Haugh2018-02-03 17:33:58 -0600
commitd835a936ac1d62f6d73db800c62a5b5f73122877 (patch)
treeb43c75129873f9faa7ee4cb0088992e406fe419c /PKGBUILD
parent07b79cbcd82c1b92167f8bfe733e272f4be6f4aa (diff)
downloadaur-d835a936ac1d62f6d73db800c62a5b5f73122877.tar.gz
mopidy-git 2.1.0.r55.g9e31e76a
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD64
1 files changed, 31 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5fe57df273a9..f6026e610775 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,48 @@
# Maintainer: Sean Haugh <seanphaugh@gmail.com>
# Contributor: Frederik "Freso" S. Olesen <freso.dk@gmail.com>
# Contributor: Trygve Aaberge <trygveaa+aur at gmail dot com>
-
+_pkgname=mopidy
+_owner=mopidy
pkgname=mopidy-git
-_gitname=mopidy
-pkgver=2.1.0.r38.g33856830
+pkgver=2.1.0.r55.g9e31e76a
pkgrel=1
-pkgdesc="An extensible music server written in Python"
+pkgdesc='An extensible music server written in Python'
arch=('any')
-url="http://www.mopidy.com"
+url="https://github.com/$_owner/$_pkgname"
license=('APACHE')
depends=('python2'
- 'python2-pykka'
- 'python2-requests'
- 'python2-setuptools'
- 'python2-tornado'
- 'gst-python2'
- 'gst-plugins-base'
- 'gst-plugins-good'
- 'gst-plugins-ugly')
-makedepends=('git')
+ 'python2-pykka'
+ 'python2-requests'
+ 'python2-tornado'
+ 'gst-python2'
+ 'gst-plugins-base'
+ 'gst-plugins-good'
+ 'gst-plugins-ugly')
+makedepends=('git'
+ 'python2-setuptools')
optdepends=('gst-libav: AAC+ and WMA support'
- 'mopidy-spotify: Spotify backend'
- 'mopidy-scrobbler: Last.FM scrobbler'
- 'mopidy-MPRIS: MPRIS frontend')
+ 'mopidy-spotify: Spotify backend'
+ 'mopidy-scrobbler: Last.FM scrobbler'
+ 'mopidy-MPRIS: MPRIS frontend')
+provides=("$_pkgname=$pkgver-$pkgrel")
conflicts=('mopidy')
-provides=("mopidy=$pkgver-$pkgrel")
-source=('git+https://github.com/mopidy/mopidy.git'
- 'mopidy@.service'
- 'mopidy-user.service')
+source=("git+https://github.com/$_owner/$_pkgname"
+ 'mopidy@.service'
+ 'mopidy-user.service')
md5sums=('SKIP'
- 'cdda1474b91b1e35a909e93fc8305599'
- '81de34714bf80d638df34fc3469bd3f5')
+ 'cdda1474b91b1e35a909e93fc8305599'
+ '81de34714bf80d638df34fc3469bd3f5')
pkgver() {
- cd "$_gitname"
- git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ cd "$_pkgname"
+ git describe --long | sed -r 's/^v//; s/([^-]*-g)/r\1/; s/-/./g'
}
package() {
- cd "$_gitname"
- python2 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
-
- install -Dm644 "$srcdir/mopidy@.service" "$pkgdir/usr/lib/systemd/system/mopidy@.service"
- install -Dm644 "$srcdir/mopidy-user.service" "$pkgdir/usr/lib/systemd/user/mopidy.service"
- install -Dm644 "$srcdir/$_gitname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$_pkgname"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ install -Dm644 "$srcdir/mopidy@.service" "$pkgdir/usr/lib/systemd/system/mopidy@.service"
+ install -Dm644 "$srcdir/mopidy-user.service" "$pkgdir/usr/lib/systemd/user/mopidy.service"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim:set ts=2 sw=2 et:
+# vim:set ts=2 sw=2 noet: