summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortonyfinn2020-01-03 17:23:38 +0000
committertonyfinn2020-01-03 17:23:38 +0000
commit49790570d40d92d939a1f25c232460850a5249cd (patch)
treeebd826c886694d155a29d3e3b6f3222a4dda33c8 /PKGBUILD
parentf949f8f8e1ae0e36692a9599e06b26b61a825cd7 (diff)
downloadaur-49790570d40d92d939a1f25c232460850a5249cd.tar.gz
Update to Mopidy 3/Python 3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d28f040b2a91..8e75248ec1a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
-# Maintainer: scsnow54@gmail.com
+# Maintainer: Tony Finn <aur at tonyfinn dot com>
+# Contributor: scsnow54@gmail.co
pkgname=mopidy-podcast-itunes
_pypiname=Mopidy-Podcast-iTunes
-pkgver=2.0.0
+pkgver=3.0.0
pkgrel=1
pkgdesc="Mopidy-Podcast extension for searching and browsing podcasts on the iTunes Store"
arch=('any')
url="https://github.com/tkem/mopidy-podcast-itunes"
license=('APACHE')
depends=(
- 'python2-setuptools'
- 'mopidy>=1.1'
- 'mopidy-podcast>=2.0'
- 'python2-pykka>=1.1'
- 'python2-requests>=2.0'
+ 'python-setuptools'
+ 'python>=3.0',
+ 'mopidy>=3.0'
+ 'mopidy-podcast>=3.0'
+ 'python-pykka>=2.0.1'
+ 'python-requests>=2.0'
)
-makedepends=('python2' 'git')
+makedepends=('python' 'git')
source=("https://pypi.python.org/packages/source/M/${_pypiname}/${_pypiname}-${pkgver}.tar.gz")
-md5sums=('48e1d489010f52329a044d951460ec34')
+md5sums=('d6fc73c113eb462b2f81b816a8695b0b')
package() {
cd "$srcdir/$_pypiname-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ python3 setup.py install --root="$pkgdir/" --optimize=1
}