summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Petitjean2015-06-08 16:57:18 +0200
committerAlexandre Petitjean2015-06-08 16:57:18 +0200
commit60bf30da45f1fba25f344435496cd450f2c2b390 (patch)
tree1102a15a8bcafdb8b688b4aa74665bac61c25efe /PKGBUILD
downloadaur-60bf30da45f1fba25f344435496cd450f2c2b390.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5995fbf205d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alexandre Petitjean <alpetitjean at gmail dot com>
+
+pkgname=mopidy-spotify
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="Mopidy extension for playing music from Spotify"
+arch=('any')
+url="http://www.mopidy.com"
+license=('APACHE')
+depends=(
+ 'mopidy>=1.0'
+ 'python2-pykka>=1.1'
+ 'pyspotify>=1.9'
+ 'pyspotify<2'
+ 'python2-setuptools')
+makedepends=('python2')
+provides=('mopidy-spotify')
+source=("https://github.com/mopidy/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('11aea06f45de81b544d25b1137a685ed')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: