summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorclintval2017-11-01 13:34:19 -0700
committerclintval2017-11-01 13:34:19 -0700
commit33c0d5ab8c4ff28fc2277f08727d68e4480e558a (patch)
treeff6affe44445f22930b3341953b28dd459e685f6 /PKGBUILD
downloadaur-33c0d5ab8c4ff28fc2277f08727d68e4480e558a.tar.gz
First commit with PKBUILD and .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45e1531ab359
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname=mosdepth
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Fast BAM/CRAM depth calculation for WGS, exome, or targeted sequencing"
+arch=('i686' 'x86_64')
+url="https://github.com/brentp/mosdepth"
+license=('MIT')
+depends=('')
+provides=('mosdepth')
+conflicts=('mosdepth')
+source=(https://github.com/brentp/"${pkgname}"/releases/download/v"${pkgver}"/"${pkgname}")
+md5sums=('9a718afa538e81a0dc4dfb9b714955a2')
+
+package() {
+ mkdir -p "${pkgdir}"/usr/bin/
+
+ cp "${pkgname}" "${pkgdir}"/usr/bin/"${pkgname}"
+ chmod +x "${pkgdir}"/usr/bin/"${pkgname}"
+}