summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMidori2022-06-06 11:39:13 +0900
committerMidori2022-06-06 11:39:13 +0900
commit24d55e4572fb51c21475a6cf1968a60bb69d6792 (patch)
treee8e310eb0dc22ef462735139874a24ed733bde7f /PKGBUILD
parenta957ee355e170e72c13a3ef9ed80b3e163d62b83 (diff)
downloadaur-24d55e4572fb51c21475a6cf1968a60bb69d6792.tar.gz
v3.9.0-2
- upadte PKGBUILD & default remote addr
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d2f57a132e9..33507cfbd178 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=mosdns
pkgname=${_pkgname}-bin
pkgver=3.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Plug-in configured DNS forwarder/server"
arch=('x86_64')
url="https://github.com/IrineSistiana/mosdns/"
@@ -13,11 +13,13 @@ optdepends=('v2ray-domain-list-community: geosite.dat'
backup=('etc/mosdns/config.yaml')
provides=('mosdns')
conflicts=('mosdns' 'mosdns-git')
-source=("$pkgname-$pkgver.zip::https://github.com/IrineSistiana/mosdns/releases/download/v${pkgver}/mosdns-linux-amd64.zip")
-sha256sums=('ddcdb7eb7d8d4783edfd7c9e60b719837407b2cf8abdc292413d03f6a7718652')
+source=("$pkgname-$pkgver.zip::https://github.com/IrineSistiana/mosdns/releases/download/v${pkgver}/mosdns-linux-amd64.zip" "service" "config.yaml")
+sha256sums=('ddcdb7eb7d8d4783edfd7c9e60b719837407b2cf8abdc292413d03f6a7718652'
+ 'b73feace50f17752d7a8f3012e546a6d05bfb13ba4946c93b82d511af974719a'
+ 'cd7f17517edead1f49b297b60ae510a7608607ea9293bbc5ecb8521163268116')
package() {
install -Dm755 mosdns "$pkgdir"/usr/bin/mosdns
- install -Dm644 ../service "$pkgdir"/usr/lib/systemd/system/mosdns.service
- install -Dm644 ../config.yaml "$pkgdir"/etc/mosdns/config.yaml
+ install -Dm644 service "$pkgdir"/usr/lib/systemd/system/mosdns.service
+ install -Dm644 config.yaml "$pkgdir"/etc/mosdns/config.yaml
}