summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMidori2022-11-14 12:37:58 +0900
committerMidori2022-11-14 12:37:58 +0900
commit9b5cbd6adbb59754de6e2a9055af340d805d8644 (patch)
tree8af4137ea78fbe6e06d7bc4cc3bcd38b78e36779 /PKGBUILD
parent3e33860ce0ac978a2474c10f742226a457ace9c8 (diff)
downloadaur-9b5cbd6adbb59754de6e2a9055af340d805d8644.tar.gz
v4.5.3-2
- sandboxing systemd service units
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 17 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b38c07274656..05be12b92b02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=mosdns
pkgname=${_pkgname}-bin
pkgver=4.5.3
-pkgrel=1
-pkgdesc="Plug-in configured DNS forwarder/server"
+pkgrel=2
+pkgdesc="一个 DNS 转发器"
arch=('x86_64')
url="https://github.com/IrineSistiana/mosdns/"
license=('GPL3')
@@ -12,14 +12,25 @@ optdepends=('v2ray-domain-list-community: geosite.dat'
'v2ray-rules-dat-git: geosite.dat & geoip.dat')
backup=('etc/mosdns/config.yaml')
provides=('mosdns')
-conflicts=('mosdns' 'mosdns-git')
-source=("$pkgname-$pkgver.zip::https://github.com/IrineSistiana/mosdns/releases/download/v${pkgver}/mosdns-linux-amd64.zip" "service" "config.yaml")
+
+source=(
+ "$pkgname-$pkgver.zip::https://github.com/IrineSistiana/mosdns/releases/download/v${pkgver}/mosdns-linux-amd64.zip"
+ "config.yaml"
+ "service"
+ "sysusers"
+ "tmpfiles"
+)
+
sha256sums=('c970f5a5502256d6ef0e3b9729c325f3fca96f1bc09f0573efce9f3ee1cd67a2'
- 'b85dd6e5522e558bb1282734bbb684ceee019047d7597bdbde4dc07a8d59317e'
- '5ff706ed3d6e5e8624e6f8b276ed1e476be8ebc4747043e63999c8a9f9324ea8')
+ '5ff706ed3d6e5e8624e6f8b276ed1e476be8ebc4747043e63999c8a9f9324ea8'
+ '8bb851c5413e0e25e18e9d912a35b1500b54531ea961d4fc6cc8416173311c17'
+ '2f2c9bbec87f610d4365cfa2631488a3517d3c5529e7e9942d778f550030c807'
+ '0be8eb1cdf1dd563f829c2ab86a00be4d889d22a29e34c9582caff5c2876a2e1')
package() {
install -Dm755 mosdns "$pkgdir"/usr/bin/mosdns
+ install -Dm644 sysusers "$pkgdir/usr/lib/sysusers.d/mosdns.conf"
+ install -Dm644 tmpfiles "$pkgdir/usr/lib/tmpfiles.d/mosdns.conf"
install -Dm644 service "$pkgdir"/usr/lib/systemd/system/mosdns.service
install -Dm644 config.yaml "$pkgdir"/etc/mosdns/config.yaml
}