summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMidori2023-01-16 11:17:49 +0900
committerMidori2023-01-16 11:17:49 +0900
commite5ece7ad4f541f2a5fe3a2e6268d6fb48a692277 (patch)
tree153566ce228b2e6d53f33fe3c12d3e19a1ba4466 /PKGBUILD
parent4d4a7f312f1c2eb986967684d7affe1d37f41a1f (diff)
downloadaur-e5ece7ad4f541f2a5fe3a2e6268d6fb48a692277.tar.gz
v5.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 8 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ebfabe8262f7..7403d28fa7da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,29 @@
# Maintainer: suienzan <suienzan at gmail dot com>
_pkgname=mosdns
pkgname=${_pkgname}-bin
-pkgver=4.5.3
-pkgrel=4
+pkgver=5.0.0
+pkgrel=1
pkgdesc="一个 DNS 转发器"
arch=('x86_64')
url="https://github.com/IrineSistiana/mosdns/"
license=('GPL3')
-optdepends=('v2ray-domain-list-community: geosite.dat'
- 'v2ray-geoip: geoip.dat'
- 'v2ray-rules-dat-git: geosite.dat & geoip.dat'
- 'redis: redis support in cache plugin')
-backup=('etc/mosdns/config.yaml')
provides=('mosdns')
source=(
- "$pkgname-$pkgver.zip::https://github.com/IrineSistiana/mosdns/releases/download/v${pkgver}/mosdns-linux-amd64.zip"
- "config.yaml"
+ "$pkgname-$pkgver.zip::https://github.com/IrineSistiana/mosdns/releases/download/v${pkgver//_/-}/mosdns-linux-amd64.zip"
"service"
"sysusers"
"tmpfiles"
)
-sha256sums=('c970f5a5502256d6ef0e3b9729c325f3fca96f1bc09f0573efce9f3ee1cd67a2'
- '5ff706ed3d6e5e8624e6f8b276ed1e476be8ebc4747043e63999c8a9f9324ea8'
+sha256sums=('70e18bc31de9e6fbfa17d3f82316394eab201139475ab134d2e6122aca0976ff'
'8bb851c5413e0e25e18e9d912a35b1500b54531ea961d4fc6cc8416173311c17'
- '98fe6799dea2f84edcc89c01102cf224afb89c745a624734ea93cf2750398f5d'
- '0be8eb1cdf1dd563f829c2ab86a00be4d889d22a29e34c9582caff5c2876a2e1')
+ 'e6bc5034452123491e3901e2741183d528a29b00f1c01d6bbbb204549fee7306'
+ '73c47567934255c4030ab06798a602989c257c187cf0c00132fbc839c902b096')
package() {
install -Dm755 mosdns "$pkgdir"/usr/bin/mosdns
- install -Dm644 sysusers "$pkgdir/usr/lib/sysusers.d/mosdns.conf"
- install -Dm644 tmpfiles "$pkgdir/usr/lib/tmpfiles.d/mosdns.conf"
+ install -Dm644 sysusers "$pkgdir"/usr/lib/sysusers.d/mosdns.conf
+ install -Dm644 tmpfiles "$pkgdir"/usr/lib/tmpfiles.d/mosdns.conf
install -Dm644 service "$pkgdir"/usr/lib/systemd/system/mosdns.service
- install -Dm644 config.yaml "$pkgdir"/etc/mosdns/config.yaml
}