summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew O'Neill2017-11-18 19:24:26 -0500
committerAndrew O'Neill2017-11-18 19:24:26 -0500
commit5331cfdf90e590f64ef99de672a2212c8073a03e (patch)
treecc0de2eb3bb80fcf523cebf74b5a78330c428f10 /PKGBUILD
parent11fc917b57f3d735c914eef7d8953ce0e24a2561 (diff)
downloadaur-5331cfdf90e590f64ef99de672a2212c8073a03e.tar.gz
Minor PKGBUILD changes after new adoption
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f9ffb1adbb50..b8dbf4a93783 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
-# Maintainer: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
+# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
+# Contributor: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
pkgname=mothur
pkgver=1.39.5
-pkgrel=1
-pkgdesc="computational microbial ecology"
+pkgrel=2
+pkgdesc="A bioinformatics program for analyzing microbial communities"
arch=('i686' 'x86_64')
url="https://www.mothur.org/"
license=('GPL3')
depends=('boost-libs')
makedepends=('boost')
-
-source=("$pkgname-$pkgver.tar.gz::https://github.com/mothur/mothur/archive/v$pkgver.tar.gz")
+source=(https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz)
+sha256sums=('9f1cd691e9631a2ab7647b19eb59cd21ea643f29b22cde73d7f343372dfee342')
prepare() {
- cd $srcdir/$pkgname-$pkgver
+ cd $pkgname-$pkgver
sed -e 's|BOOST_LIBRARY_DIR="\\"Enter_your_boost_library_path_here\\""|BOOST_LIBRARY_DIR = /usr/lib|' \
-e 's|BOOST_INCLUDE_DIR="\\"Enter_your_boost_include_path_here\\""|BOOST_INCLUDE_DIR = /usr/include|' \
@@ -21,16 +22,14 @@ prepare() {
}
build() {
- cd $srcdir/$pkgname-$pkgver
+ cd $pkgname-$pkgver
make
}
package() {
- cd $srcdir/$pkgname-$pkgver
+ cd $pkgname-$pkgver
install -Dm755 mothur $pkgdir/usr/bin/mothur
install -Dm755 uchime $pkgdir/usr/bin/uchime
}
-
-md5sums=('1f826ea4420e6822fc0db002c5940b92')