summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew O'Neill2021-08-31 17:29:49 -0400
committerAndrew O'Neill2021-08-31 17:29:49 -0400
commit9aa8111eecd02585ba71cdb0b70277171408fc70 (patch)
tree6a325d3f106afed534b4033e00d885242a708787 /PKGBUILD
parent2cc7191667f5c5339231717700e1ecaf53f66c77 (diff)
downloadaur-9aa8111eecd02585ba71cdb0b70277171408fc70.tar.gz
Version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b39e1d990473..d6486a2107eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
pkgname=mothur
-pkgver=1.45.3
+pkgver=1.46.0
pkgrel=1
pkgdesc='A bioinformatics program for analyzing microbial communities.'
arch=('x86_64')
@@ -11,15 +11,16 @@ license=('GPL3')
depends=('boost-libs')
makedepends=('boost' 'hdf5')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('865317569260ab7fa8fde2cbe00bcc05e6402dcd97267615d863ede145f381e8')
+sha256sums=('0bb833b82c8841dca8cecfa58c93d537ec55f4a66d0def40916668a18baf6424')
prepare() {
cd "${pkgname}-${pkgver}"
- sed -i '87d' source/mothur.h
- sed -i 's/skipUchime),/skipUchime), source\/,/g' Makefile
- sed -i 's/1.45.2/1.45.3/g' Makefile Makefile_cluster
-# rm splitkmerdist.cpp splitkmerdist.hpp
+ # I hate this so much.
+ sed -i '87d' source/mothur.h
+ sed -i '13 i \#include <memory>' source/writer.h
+ sed -i 's/skipUchime),/skipUchime), source\/,/g' Makefile
+ sed -i 's/CXXFLAGS = -O3/CXXFLAGS = -O3 -std=c++11/' source/uchime_src/makefile
}
build() {