summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJose Riha2022-03-30 01:16:36 +0200
committerJose Riha2022-03-30 01:16:36 +0200
commitf0718cc353c8c1c858aafce986d216bbefe673ce (patch)
treee63568a670ba306732e81775343922187c7dd0f1 /PKGBUILD
parent9599a629452c00b828daa46876347ace88de687d (diff)
downloadaur-f0718cc353c8c1c858aafce986d216bbefe673ce.tar.gz
Update to work with the current branch.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 14 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2caaed6507ff..68421f7482d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: AlphaJack <alphajack at tuta dot io>
+# Maintainer: Jose Riha <jose 1711 gmail com>
# Contributor: Jeremy MJ <jskier@gmail.com>
# Contributor: Niklas Hedlund <nojan1989@gmail.com>
-pkgname="motioneye-git"
-pkgver=0.42.r38.g25ee819
+pkgname=motioneye-git
+pkgver=0.42.1.r310.g601bcfb
pkgrel=1
pkgdesc="A web frontend for the motion daemon, Python 3 development branch"
url="https://github.com/ccrisan/motioneye.git"
@@ -15,18 +16,18 @@ depends=("motion"
"python-jinja"
"python-pillow"
"python-pycurl"
- "python-tornado5" # required for @asynchronous handler, deprecated in python-tornaod 5.1 and removed in 6.0
+ "python-tornado"
"python-six")
makedepends=("python-setuptools")
backup=("etc/motioneye/motioneye.conf")
-source=("git+$url#branch=python3"
+source=("git+$url#branch=dev"
"motioneye.tmpfiles"
"motioneye.service")
-sha256sums=("SKIP"
- "e7447bf9ab023326e7c396ecad8933eaa3399b16d844a34f288cf55b8c917bfa"
- "68880de868b98c5017e2ab6b87122c241873daf393c084710d81b19c9d0663da")
+sha256sums=('SKIP'
+ 'e7447bf9ab023326e7c396ecad8933eaa3399b16d844a34f288cf55b8c917bfa'
+ '55a72fe49d2bacbc1cc9231ef80afab3859a48c558fe030f46ce8c7d3a95341e')
backup=("etc/motioneye/motioneye.conf")
-install="motioneye.install"
+install=motioneye.install
pkgver(){
cd "motioneye"
@@ -34,22 +35,16 @@ pkgver(){
}
prepare(){
- cd "motioneye"
+ cd motioneye/motioneye
sed -i "extra/motioneye.conf.sample" \
- -e 's|^run_path /var/run$|run_path /var/lib/motioneye|'
-}
-
-build(){
- cd "motioneye"
- python setup.py build
+ -e 's|^run_path /run/motioneye$|run_path /var/run/motioneye|'
}
package(){
- cd "motioneye"
- python setup.py install --root="$pkgdir" --optimize=1
+ cd motioneye
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="${pkgdir}" --ignore-installed --no-deps .
# configuration folder must be writable by motioneye
- install -D -m 660 "extra/motioneye.conf.sample" "$pkgdir/etc/motioneye/motioneye.conf"
+ install -D -m 660 "motioneye/extra/motioneye.conf.sample" "$pkgdir/etc/motioneye/motioneye.conf"
install -D -m 644 "$srcdir/motioneye.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/motioneye.conf"
install -D -m 644 "$srcdir/motioneye.service" "$pkgdir/usr/lib/systemd/system/motioneye.service"
}
-