summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGiovanni Harting2024-03-23 19:32:42 +0100
committerGiovanni Harting2024-03-23 19:32:42 +0100
commit46d82b8b97e2e1adac7c0c4380dae77f27767126 (patch)
tree472a9c3cd316a7ab385fe1655118da80e7260118 /PKGBUILD
parent3b0801cb0b6142ec2c5ee60e257809ee0af2f866 (diff)
downloadaur-46d82b8b97e2e1adac7c0c4380dae77f27767126.tar.gz
upgpkg: motionplus 0.2.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 23 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 316e0ee1827d..09cb47269464 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,32 @@
# Maintainer: Giovanni Harting <539@idlegandalf.com>
pkgname=motionplus
-pkgver=0.1.1
-pkgrel=4
-pkgdesc="Monitor and record video signals from many types of cameras"
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='Monitor and record video signals from many types of cameras'
arch=(x86_64)
-license=(GPL)
-url="https://github.com/Motion-Project/motionplus"
-depends=(sqlite ffmpeg libmicrohttpd libwebp postgresql-libs mariadb-libs)
+license=(GPL-3.0-or-later)
+url='https://github.com/Motion-Project/motionplus'
+depends=(
+ sqlite
+ ffmpeg
+ libmicrohttpd
+ libwebp
+ postgresql-libs
+ mariadb-libs
+ libjpeg-turbo
+ alsa-lib
+ libpulse
+ glibc
+ gcc-libs
+ fftw
+)
optdepends=('gettext: native language support')
backup=('etc/motionplus/motionplus.conf')
-source=("https://github.com/Motion-Project/motionplus/archive/refs/tags/release-0.1.1.tar.gz"
- 'motionplus.service'
- "https://github.com/Motion-Project/motionplus/commit/af632f831127499ee541d9c719a930321718f294.patch")
-b2sums=('7fcc10bc87948108141acb3f3b4d8ca1759b365c3a220e0eb8c0ff92cf0091e50737ac6a70ee0b18263f3c012b9ae197d026ece049fc2c79ff194b96fc9a8dfc'
- 'baf8c1cd1b742b834e3faa45315d7187e89d2e439751ee8a99fbde117fd504830d5990540be96c9672ec03efdc9c8fd2b87bd507ab74fe73a30cf16826a3f4f6'
- '0eb61b732bdaf8d6b9e7d55333c28c732b51338829bb615cc6ef69445b325b8eaf3e8f11bca3b2e08366a8317a211f04fb1af61f1d763e50a0e8b2fa71b01d16')
-
-prepare() {
- cd $pkgname-release-$pkgver
- patch -Np1 -i "$srcdir"/af632f831127499ee541d9c719a930321718f294.patch
-}
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/release-$pkgver.tar.gz"
+ $pkgname.service)
+b2sums=('196d6ea51cb76428986be84463616c4136c63de12eb9e2f0dd8b43dd37533cd6a83aef363441dd254fbcc2d3dd256589e8bda090e2861e2844a611a6ef17ff32'
+ 'baf8c1cd1b742b834e3faa45315d7187e89d2e439751ee8a99fbde117fd504830d5990540be96c9672ec03efdc9c8fd2b87bd507ab74fe73a30cf16826a3f4f6')
build() {
cd $pkgname-release-$pkgver