summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorweearc2020-05-03 16:22:36 +0800
committerweearc2020-05-03 16:22:36 +0800
commitdadbc2d219fc757040371a7d077b2554660fefa0 (patch)
treef981294c5814afe8440b9a2988f4bfceaadab821 /PKGBUILD
parent3b8f6ad67ea9bbd99ec316f366867305463f86fc (diff)
downloadaur-dadbc2d219fc757040371a7d077b2554660fefa0.tar.gz
fix build failure
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 28 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbf25f0b214d..fc0d389ebc2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=motrix
_pkgname=Motrix
pkgver=v1.4.1
_pkgver=1.4.1
-pkgrel=7
+pkgrel=8
epoch=
pkgdesc="elegent downloading tool frontend for aria2c,using vue(release version)"
arch=("x86_64")
@@ -15,8 +15,8 @@ depends=(
'libxcb'
)
makedepends=('curl'
- 'yarn'
- 'npm')
+ 'npm'
+ )
checkdepends=()
optdepends=()
provides=()
@@ -27,12 +27,10 @@ options=()
install=
changelog=
source=("Motrix.desktop"
- "aria2.conf"
"motrix"
"Motrix.tar.gz"::"https://github.com/agalwood/Motrix/archive/v$_pkgver.tar.gz")
noextract=()
sha256sums=('1b799d1b1e280a27ff625cceb429b1e00c6691eb0256ded44f6a1a0310a899d4'
- '1d87b2906dd9622efcdd3695d19fd4d365f644c53dac8b517931964d4099d2c3'
'c89824e80769b0b19c66da12168f9e91fc15088d1324d6760ddad960eb006cba'
'cd10cd5c704f0d780ff501e2861a316b95c44d11b653045574ae07b9a3ccaa8b')
validpgpkeys=()
@@ -41,28 +39,28 @@ prepare() {
tar -xvf $_pkgname.tar.gz
rm $_pkgname.tar.gz
mv $_pkgname-$_pkgver $_pkgname
- echo "====================================="
- echo "Finding if you are in China..."
- curl https://myip.ipip.net | grep -i "中国"
- if [ $? -eq 0 ]
- then
- echo "Yes,I'm sure you are in China."
- echo "To speed up installation I'll change npm mirrors to Taobao."
- npm config set registry 'https://registry.npm.taobao.org'
- export ELECTRON_MIRROR='https://npm.taobao.org/mirrors/electron/'
- export SASS_BINARY_SITE='https://npm.taobao.org/mirrors/node-sass'
- else
- curl https://myip.ipip.net | grep -i "China"
- if [ $? -eq 0 ]
- then
- echo "Yes,I'm sure you are in China."
- echo "To speed up installation I'll change npm mirrors to Taobao."
- npm config set registry 'https://registry.npm.taobao.org'
- export ELECTRON_MIRROR='https://npm.taobao.org/mirrors/electron/'
- export SASS_BINARY_SITE='https://npm.taobao.org/mirrors/node-sass'
- fi
- fi
- echo "======================================"
+# echo "====================================="
+# echo "Finding if you are in China..."
+# curl https://myip.ipip.net | grep -i "中国"
+# if [ $? -eq 0 ]
+# then
+# echo "Yes,I'm sure you are in China."
+# echo "To speed up installation I'll change npm mirrors to Taobao."
+# npm config set registry 'https://registry.npm.taobao.org'
+# export ELECTRON_MIRROR='https://npm.taobao.org/mirrors/electron/'
+# export SASS_BINARY_SITE='https://npm.taobao.org/mirrors/node-sass'
+# else
+# curl https://myip.ipip.net | grep -i "China"
+# if [ $? -eq 0 ]
+# then
+# echo "Yes,I'm sure you are in China."
+# echo "To speed up installation I'll change npm mirrors to Taobao."
+# npm config set registry 'https://registry.npm.taobao.org'
+# export ELECTRON_MIRROR='https://npm.taobao.org/mirrors/electron/'
+# export SASS_BINARY_SITE='https://npm.taobao.org/mirrors/node-sass'
+# fi
+# fi
+# echo "======================================"
sed -i '/"dmg"/,/"linux"/{//!d}' $_pkgname/package.json
sed -i '/"dmg"/d' $_pkgname/package.json
sed -i '/"deb"/d' $_pkgname/package.json
@@ -75,8 +73,7 @@ prepare() {
build() {
cd $_pkgname/
- yarn
- yarn run build
+ npm install && npm run build:dir
}
package() {
install -d ${pkgdir}/opt
@@ -87,7 +84,7 @@ package() {
install -Dm644 ${srcdir}/$_pkgname/build/256x256.png ${pkgdir}/usr/share/icons/$pkgname.png
install -Dm 777 ${srcdir}/motrix ${pkgdir}/usr/bin
install -Dm 644 ${srcdir}/Motrix.desktop ${pkgdir}/usr/share/applications
- rm ${pkgdir}/opt/motrix/resources/engine/aria2.conf
- cp -p ${srcdir}/aria2.conf ${pkgdir}/opt/motrix/resources/engine/aria2.conf
+# rm ${pkgdir}/opt/motrix/resources/engine/aria2.conf
+# cp -p ${srcdir}/aria2.conf ${pkgdir}/opt/motrix/resources/engine/aria2.conf
rm -rf ${srcdir}
}