summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-04-22 11:40:17 +0200
committerXZS2016-04-22 11:40:17 +0200
commitbfd89f85481e89373e666d755be163067456cdf6 (patch)
tree74cbbf0410cd397ba11ebd20e2626490e211dd46 /PKGBUILD
parent65cc0671358d6ed972f7cafcba945d5613694308 (diff)
downloadaur-bfd89f85481e89373e666d755be163067456cdf6.tar.gz
exclude hidden filed in subdirectories
Despite the wild card * not coping hidden files, this does not exclude such in subdirectories. A reliable method to exclude files by a pattern like "starting with a dot" would be rsync. But to not pull it in as an additional dependency, copy and find are preferred.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 42a987f0c900..28c29c060098 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,8 +53,8 @@ build() {
eval "package_$pkgname()" '{
prepare_target
- install -d "$destdir/$id"
- cp --no-preserve=ownership,mode -r * "$destdir/$id"
+ cp --no-preserve=ownership,mode -r . "$destdir/$id"
+ find "$destdir/$id" -mindepth 1 -name ".*" -exec rm -rf '{}' +
}'
for target in "${optdepends[@]}"; do