summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-04-22 11:39:49 +0200
committerXZS2016-04-22 11:39:49 +0200
commit1fd8c3fa6a8a92abcaa53ce70ad45ac0fc200659 (patch)
tree08165ac55c68939d43e78ef79ba638c2ba06305a /PKGBUILD
parenta95d2803c286b94a9afaa19a905c484911c06551 (diff)
downloadaur-1fd8c3fa6a8a92abcaa53ce70ad45ac0fc200659.tar.gz
exclude hidden filed in subdirectories
Despite the wild card * not coping hidden files, this does not exclude such in subdirectories. A reliable method to exclude files by a pattern like "starting with a dot" would be rsync. But to not pull it in as an additional dependency, copy and find are preferred.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d0ee2db22dc..6ed91d9bc61a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -54,8 +54,8 @@ build() {
eval "package_$pkgname()" '{
prepare_target
- install -d "$destdir/$id"
- cp --no-preserve=ownership,mode -r * "$destdir/$id"
+ cp --no-preserve=ownership,mode -r . "$destdir/$id"
+ find "$destdir/$id" -mindepth 1 -name ".*" -exec rm -rf '{}' +
}'
for target in "${optdepends[@]}"; do