summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-02-16 11:48:24 +0100
committerXZS2016-02-16 11:48:24 +0100
commitd025a8143dd719345dc1c734a9cd20e661c95e3b (patch)
tree7c25f39601f53f55756094ff74c62915c97ceeac /PKGBUILD
parent461c968a1d97e2c9afcd1cfc6e2fc259124867ed (diff)
downloadaur-d025a8143dd719345dc1c734a9cd20e661c95e3b.tar.gz
look for JSON descriptions in subdirectories
The extension recently moved all sources in a subdirectory. As the pkgver function even runs before prepare, it is not possible to move its contents down a directory level. Thus, the JSON description is still in a subdirectory in this point of time.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fdd402d207d2..3b6acd92bdef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mozilla-extension-gnotifier-git
pkgver=1.9.2
-pkgrel=2
+pkgrel=3
pkgdesc='Add-on for Firefox and Thunderbird to enable integration with GNOME native notification system.'
url='https://github.com/mkiol/GNotifier'
arch=('any')
@@ -38,9 +38,9 @@ query-version() {
}
pkgver() {
- cd "$_gitname"
- sed -n 's/.*"version"\s*:\s*"\([[:digit:].]*\)"\s*,.*/\1/p' \
- *.json 2>/dev/null | tr '\n' '.'
+ find -iname '*.json' -exec sed -n \
+ 's/.*"version"\s*:\s*"\([[:digit:].]*\)"\s*,.*/\1/p' \
+ '{}' \; -quit 2>/dev/null | tr '\n' '.'
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}