summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-10-31 18:30:30 +0100
committerXZS2016-10-31 18:30:30 +0100
commitd67ffd1d6fee874c34f7ee4b5f2a2dd28d1dd3d5 (patch)
tree2d1774ce561d47a159f7a3c727defd313b6fcfcb /PKGBUILD
parent724958c92737abbe902517afbe4e106a32f43b21 (diff)
downloadaur-d67ffd1d6fee874c34f7ee4b5f2a2dd28d1dd3d5.tar.gz
model compatibility by default
Despite the information given out via the API, Firefox actually permits installation of some extensions reported incompatible, which then work fine. This is because Firefox' internal mechanism determines that these extensions should be compatible by itself and subsequently refrains from even querying the API to begin with. The version range in the depends array should reflect this. The new condition set models how Firefox and Thunderbird decide compatibility to smoothen future updates.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7610a9b4f1a..b0bfa7de39cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=mozilla-extension-stylish
pkgver=2.0.7
-pkgrel=1
+pkgrel=2
pkgdesc='Customize your favorite web sites with user styles.'
url='https://userstyles.org/'
license=('GPL')
@@ -63,9 +63,18 @@ for target in "${optdepends[@]}"; do
done
optdepends=()
+
version-range() {
- local emid=$(emid $1)
- echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ if [ -z "$(sparql "?x em:type ?type. filter(?type in ('2', '64'))")" ] ||
+ [ -n "$(sparql "?x em:strictCompatibility 'true'")" ] ||
+ { [ -e chrome.manifest ] &&
+ grep '^binary-component[ \t]' chrome.manifest ; }
+ then
+ local emid=$(emid $1)
+ echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ else
+ echo "$1>$(version min $(emid $1))"
+ fi
}
emid() {