summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormanhandle50772023-08-29 18:15:04 +0000
committerPolarian2023-08-29 18:15:04 +0000
commit01c82185de0fe747d9a0baea25e0a4ce68281af7 (patch)
tree064a3b5bef6cd1fb6bd65fa41fd335e93a760d9f /PKGBUILD
parentdce70f002584bef49c89bf247f08d73b611ae3a3 (diff)
downloadaur-01c82185de0fe747d9a0baea25e0a4ce68281af7.tar.gz
upgrade to v2.16.1 (#2)
Co-authored-by: Rafał Wyszomirski <maqibjbd5@mozmail.com> Reviewed-on: https://git.polarian.dev/AUR/mozillavpn/pulls/2 Co-authored-by: manhandle5077 <m6vuthzbw@mozmail.com> Co-committed-by: manhandle5077 <m6vuthzbw@mozmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 19 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 52549f4467b8..e955afb4b417 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,17 @@
# Contributor: Tavian Barnes <tavianator@tavianator.com>
# Contributor: jhorcl
# Contributor: flbzh <frederic_lebouc (a) yahoo.fr>
+# Contributor: Rafał Wyszomirski <m6vuthzbw at mozmail dot com>
pkgname=mozillavpn
-pkgver=2.15.0
+pkgver=2.16.1
pkgrel=1
pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
arch=('x86_64')
url="https://mozilla.org/products/vpn"
license=('MPL2')
+# See issue: https://github.com/briansmith/ring/issues/1444
+options=('!lto')
depends=('polkit'
'libxcb'
'libxmu'
@@ -28,20 +31,26 @@ depends=('polkit'
'qt6-5compat'
'qt6-shadertools'
'hicolor-icon-theme'
- 'wireguard-tools'
- 'WIREGUARD-MODULE'
- 'openresolv')
-makedepends=('cmake' 'qt6-tools' 'go' 'flex' 'clang' 'cargo' 'python-yaml' 'python-lxml' 'python-glean_parser' 'yamllint')
-optdepends=('qt6-wayland: for Wayland support')
+ 'wireguard-tools')
+makedepends=('git'
+ 'cmake'
+ 'qt6-tools'
+ 'go'
+ 'clang'
+ 'cargo'
+ 'python-yaml'
+ 'python-lxml'
+ 'python-glean-parser'
+ 'yamllint')
+optdepends=('qt6-wayland: for Wayland support'
+ 'openresolv: for resolv.conf management')
# https://github.com/mozilla-mobile/mozilla-vpn-client
source=(${pkgname}-v${pkgver}::git+https://github.com/mozilla-mobile/mozilla-vpn-client.git#tag=v${pkgver})
-sha256sums=(SKIP)
+sha256sums=('SKIP')
prepare() {
cd ${pkgname}-v${pkgver}
-
- rm -rf build
- mkdir build
+ mkdir -p build
git submodule init
git submodule update