summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavier C. Llano2022-11-15 19:06:54 -0800
committerXavier C. Llano2022-11-15 19:06:54 -0800
commit0f5fefa23942bfcbfecd1ed420107ff25ccad85f (patch)
tree02341ba2fa5cbc297cd21642645fae861ef50580 /PKGBUILD
parentadc040ab9388ce002593f341fbea293df1ec7212 (diff)
downloadaur-0f5fefa23942bfcbfecd1ed420107ff25ccad85f.tar.gz
2.11.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64850758e700..a1adab096b13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: jhorcl
# Contributor: flbzh <frederic_lebouc (a) yahoo.fr>
pkgname=mozillavpn
-pkgver=2.10.1
-_debian_series=jammy1
+pkgver=2.11.0
+_debian_series=kinetic1
pkgrel=1
pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
arch=('i686' 'x86_64')
@@ -33,15 +33,15 @@ depends=('polkit'
makedepends=('cmake' 'qt6-tools' 'go' 'flex' 'python-yaml' 'python-lxml' 'clang' 'cargo')
# https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+packages
source=("https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz" "issue_6676.patch")
-sha256sums=('1479094c505469cad9c5a03b335d079774974c9007fc3ccbc0912e2a9884e6a1'
- '7bad4fa399c1092247a262e1efdcd6d3b57cea902949575ab2ace1d865903ea7')
+sha256sums=('9f26fd7da7e486798fafa01657d346d163534edbb33e5096aef4559d5dd6959f'
+ '1d2dc2b0be6e482aaf2eb820024f53634395d1d94e0eb3add81cdc0e64dc5152')
build() {
cd "${pkgname}-${pkgver}"
rm -rf build && mkdir build && cmake -S . -B build -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
# fix compiling with Qt >= 6.4
- patch src/connectionbenchmark/benchmarktaskdownload.cpp < ../issue_6676.patch
+ patch -p0 < ../issue_6676.patch
cmake --build build -j6
}