summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2023-12-11 17:07:13 -0800
committerxiota2023-12-11 17:08:38 -0800
commit21353c9d2ecb6d0c2e67ec6280d5ccfb07a4396b (patch)
tree5aba1600f4acaa1118c002eecec6946752874d22 /PKGBUILD
parente6bfc8d93ef96581e7d7c0a4829616e15b661e8f (diff)
downloadaur-21353c9d2ecb6d0c2e67ec6280d5ccfb07a4396b.tar.gz
cosmetic changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD72
1 files changed, 44 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23d3c05c54f3..a21f32c0a293 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,67 +1,83 @@
# Maintainer XavierCLL <xavier.corredor.llano (a) gmail.com>
-# Contributor: xiota / aur.chaotic.cx
# Contributor: Utsav <aur (a) utsav2 [.] dev>
# Contributor: Tavian Barnes <tavianator@tavianator.com>
# Contributor: jhorcl
# Contributor: flbzh <frederic_lebouc (a) yahoo.fr>
# Contributor: RafaƂ Wyszomirski <m6vuthzbw at mozmail dot com>
+## useful urls:
+# https://vpn.mozilla.org
+# https://github.com/mozilla-mobile/mozilla-vpn-client
+# https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+packages
+
pkgname=mozillavpn
pkgver=2.19.0
-_debian_series=mantic1
-pkgrel=4
-pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox"
+pkgrel=5
+pkgdesc="Fast, secure, and easy to use VPN from the makers of Firefox"
arch=('x86_64')
url="https://vpn.mozilla.org"
license=('MPL2')
options=('!lto')
depends=(
- 'polkit'
+ 'dbus'
+ 'freetype2'
+ 'hicolor-icon-theme'
+ 'libtiff'
'libxcb'
+ 'libxdmcp'
'libxmu'
'libxrender'
- 'libtiff'
- 'libxdmcp'
- 'dbus'
- 'freetype2'
+ 'polkit'
+ 'qt6-5compat'
'qt6-charts'
'qt6-declarative'
- 'qt6-websockets'
'qt6-imageformats'
'qt6-networkauth'
- 'qt6-svg'
- 'qt6-5compat'
'qt6-shadertools'
- 'hicolor-icon-theme'
+ 'qt6-svg'
+ 'qt6-websockets'
'wireguard-tools'
)
-optdepends=(
- 'resolvconf: for resolv.conf management'
- 'qt6-wayland: for Wayland support'
-)
makedepends=(
+ 'cargo'
+ 'clang'
'cmake'
- 'qt6-tools'
- 'go'
'flex'
- 'python-yaml'
+ 'go'
'python-lxml'
- 'clang'
- 'cargo'
+ 'python-yaml'
+ 'qt6-tools'
+)
+optdepends=(
+ 'qt6-wayland: for Wayland support'
+ 'resolvconf: for resolv.conf management'
)
+
install=mozillavpn.install
-# https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+packages
-source=("https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz" "mozillavpn.install")
+
+_debian_series="mantic1"
+_dl_url="https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn"
+_pkgsrc="$pkgname-$pkgver"
+source=(
+ "$_dl_url/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz"
+ "mozillavpn.install"
+)
sha256sums=('36754d1f0e2f3ff5b08cecf691b7e158981356dc53b55152d93925f1b4d87e03'
'fd50a85e735f755857a02100a9a567bdb9af439d442c4fe72c6e76c108d7b303')
build() {
- cd "${pkgname}-${pkgver}"
- cmake -S . -B build -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev
+ local _cmake_options=(
+ -B build
+ -S "$_pkgsrc"
+ -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ -Wno-dev
+ )
+
+ cmake "${_cmake_options[@]}"
cmake --build build
}
package() {
- cd "${pkgname}-${pkgver}"
- DESTDIR="${pkgdir}" cmake --install build
+ DESTDIR="$pkgdir" cmake --install build
}