summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavierCLL2021-09-18 14:21:43 -0700
committerXavierCLL2021-09-18 14:21:43 -0700
commit339b8a9c19eccf58211c12167c48ae142f035247 (patch)
tree73d9a834a7149652783e8ba2e62a5a77fdc9efc5 /PKGBUILD
parent2340fc22b7023a5b7513c4bba32a4426da28b892 (diff)
downloadaur-339b8a9c19eccf58211c12167c48ae142f035247.tar.gz
v2.5.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3bbbfa5a54a1..3f130a2512a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor Tavian Barnes <tavianator@tavianator.com>
# Contributor jhorcl
pkgname=mozillavpn
-pkgver=2.4.1
-_debian_series=hirsute1
+pkgver=2.5.0
+_debian_series=hirsute2
pkgrel=1
pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
arch=('i686' 'x86_64')
@@ -32,16 +32,26 @@ makedepends=('qt5-tools' 'go' 'flex')
# https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+packages
source=(
"https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz"
- "https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}-${_debian_series}.debian.tar.xz")
-sha256sums=('41072b7554cd0aaf5f66c90c088bf6b88e241fc02723c251a2f61aedcd99de4e'
- 'deeaed77c2835786e0d36c572440549c40d1f3c909f4ca6026163d20c11634fa')
+ "https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}-${_debian_series}.debian.tar.xz"
+ "libgo.patch")
+sha256sums=('2549774bd742e08cdbe2177fe43f2ce514f2dd102b1c6f68e587ce1fdbc7a71a'
+ '7a76fc487168bfde3b31361f380ca93feb59517e8f31c8153fa7fb67cfe37719'
+ '3c5b7047481922a1b5c6673ae78750d1af8e9dbde85632804356c829dadfa301')
build() {
+ cd "${pkgname}-${pkgver}"
+
+ # https://github.com/mozilla-mobile/mozilla-vpn-client/pull/1490
+ # https://github.com/mozilla-mobile/mozilla-vpn-client/issues/1814
+ patch -Np1 -i "${srcdir}/libgo.patch" src/src.pro
+
qmake PREFIX=/usr CONFIG+=production
+ python scripts/importLanguages.py
make
}
package() {
+ cd "${pkgname}-${pkgver}"
make INSTALL_ROOT="$pkgdir" install
install -dm 755 "$pkgdir/usr/lib/systemd/system"
install -Dm 644 "linux/mozillavpn.service" "$pkgdir/usr/lib/systemd/system"