summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUtsav Manpuria2023-03-08 22:18:11 -0800
committerUtsav Manpuria2023-03-08 22:18:11 -0800
commit5f7930ad184dc03e71831bb16f447cac6d41ce33 (patch)
tree1a679568236c35c3118ebd5f62b2d5ef33b8245a /PKGBUILD
parent536ec266e71e4e37b0534271e086c73c51bed9e1 (diff)
downloadaur-5f7930ad184dc03e71831bb16f447cac6d41ce33.tar.gz
Switched to pulling glean_parser from AUR not pip
Fixed url and license
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 43b6b2208ca2..632cb62d20b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Utsav <aur at utsav2 dot dev>
+# Maintainer: Utsav <aur (a) utsav2 [.] dev>
# Contributor: XavierCLL <xavier.corredor.llano (a) gmail.com>
# Contributor: Tavian Barnes <tavianator@tavianator.com>
# Contributor: jhorcl
@@ -6,11 +6,11 @@
pkgname=mozillavpn
pkgver=2.13.1
-pkgrel=1
+pkgrel=2
pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
arch=('x86_64')
-url="https://vpn.mozilla.org/"
-license=('GPL')
+url="https://mozilla.org/products/vpn"
+license=('MPL2')
depends=('polkit'
'libxcb'
'libxmu'
@@ -31,7 +31,7 @@ depends=('polkit'
'wireguard-tools'
'WIREGUARD-MODULE'
'openresolv')
-makedepends=('cmake' 'qt6-tools' 'go' 'flex' 'python-yaml' 'python-lxml' 'clang' 'cargo' 'python-pip')
+makedepends=('cmake' 'qt6-tools' 'go' 'flex' 'clang' 'cargo' 'python-yaml' 'python-lxml' 'python-glean_parser' 'yamllint')
# https://github.com/mozilla-mobile/mozilla-vpn-client
source=(${pkgname}-v${pkgver}::git+https://github.com/mozilla-mobile/mozilla-vpn-client.git#tag=v${pkgver})
@@ -43,8 +43,6 @@ prepare() {
rm -rf build
mkdir build
- pip install --user glean_parser
-
git submodule init
git submodule update
}