summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavierCLL2022-04-19 12:56:05 -0700
committerXavierCLL2022-04-19 12:56:05 -0700
commit694b6be87c51f689a105d8b4c8e4f6c23863079a (patch)
treec89087b7bcffa53c0fc62a20b62d8879ce065d2e /PKGBUILD
parent3d069794eeb6ce0156c87c096948111697f71076 (diff)
downloadaur-694b6be87c51f689a105d8b4c8e4f6c23863079a.tar.gz
v2.8.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbb7ff57f61b..17a0ab83c8d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: jhorcl
# Contributor: flbzh <frederic_lebouc (a) yahoo.fr>
pkgname=mozillavpn
-pkgver=2.7.0
-_debian_series=impish1
-pkgrel=3
+pkgver=2.8.0
+_debian_series=jammy1
+pkgrel=1
pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
arch=('i686' 'x86_64')
url="https://vpn.mozilla.org/"
@@ -29,18 +29,18 @@ depends=('polkit'
'wireguard-tools'
'WIREGUARD-MODULE'
'openresolv')
-makedepends=('qt6-tools' 'go' 'flex' 'python-yaml' 'clang')
+makedepends=('qt6-tools' 'go' 'flex' 'python-yaml' 'clang' 'cargo')
# https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+packages
source=(
"https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz"
"https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}-${_debian_series}.debian.tar.xz")
-sha256sums=('0aca5cc0752d30b7b120d8cf277cac6ef4e085db5f9d68fec3450030b0b1215b'
- '064e87240c6807aecfee3e22c3510d7ceb49c4f969ed041458dca6cce6ccf060')
+sha256sums=('4d6d1cf92ce330c705d7acafe8fbef45711878fb1a65ea846f5a4b7f3e9d013f'
+ 'b17bbccaa998806789bd08fc7bba5c1e10b31a4315e7cdbb2145f4929a8461e1')
build() {
cd "${pkgname}-${pkgver}"
export PATH=/usr/lib/qt6/bin/:$PATH
- python scripts/importLanguages.py
+ python scripts/utils/import_languages.py
qmake6 PREFIX=/usr CONFIG-=debug CONFIG+=release CONFIG-=debug_and_release CONFIG+=webextension
make
}