summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavier C. Llano2022-10-04 12:16:04 -0700
committerXavier C. Llano2022-10-04 12:16:04 -0700
commit9d3a5d471e1e0bf7b590c43ce8f34187f248d26e (patch)
treea6daabfe0598c37fd715526d7177f6f45038f27e /PKGBUILD
parenta22313448550871d8a6bd30f04b8bdf705b04671 (diff)
downloadaur-9d3a5d471e1e0bf7b590c43ce8f34187f248d26e.tar.gz
Fix to build with Qt 6.4 but UI is still broken
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7392f9cd0921..62cad422d00b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=mozillavpn
pkgver=2.9.0
_debian_series=jammy1
-pkgrel=1
+pkgrel=2
pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
arch=('i686' 'x86_64')
url="https://vpn.mozilla.org/"
@@ -31,13 +31,18 @@ depends=('polkit'
'openresolv')
makedepends=('cmake' 'qt6-tools' 'go' 'flex' 'python-yaml' 'python-lxml' 'clang' 'cargo')
# https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+packages
-source=("https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz")
-sha256sums=('122b2e465da3dcbb226bde38413e7969b6128553999b1fc1ad59e1e3ace311ff')
+source=("https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz" "issue_6676.patch")
+sha256sums=('122b2e465da3dcbb226bde38413e7969b6128553999b1fc1ad59e1e3ace311ff'
+ 'fa8a2af04ec62109e38f019d6c013c369d5a017c3729ed487cea31fa181339f7')
build() {
cd "${pkgname}-${pkgver}"
rm -rf build && mkdir build && cmake -S . -B build -DCMAKE_INSTALL_PREFIX=/usr
- cmake --build build
+
+ # fix compiling with Qt >= 6.4
+ patch src/connectionbenchmark/benchmarktaskdownload.cpp < ../issue_6676.patch
+
+ cmake --build build -j6
}
package() {