summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavierCLL2021-06-16 23:28:47 -0700
committerXavierCLL2021-06-16 23:28:47 -0700
commitb676bc96babb03ce53cc3d60e59455f9fb99d92f (patch)
treebe94dcae25596043ea00224821977ec09017719f /PKGBUILD
parent973eca680cfd899f523f21273b17fee205fd3975 (diff)
downloadaur-b676bc96babb03ce53cc3d60e59455f9fb99d92f.tar.gz
Chenged the source of systemd service
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8468b3d0f51f..b1076865be9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor Tavian Barnes <tavianator@tavianator.com>
pkgname=mozillavpn
pkgver=2.3.1
-pkgrel=2
+pkgrel=3
pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
arch=('i686' 'x86_64')
url="https://vpn.mozilla.org/"
@@ -19,11 +19,12 @@ depends=('polkit'
'wireguard-tools'
'WIREGUARD-MODULE')
makedepends=('qt5-tools')
+# https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+packages
source=(
- "https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/$pkgname/$pkgver-groovy1/${pkgname}_${pkgver}.orig.tar.gz"
- "mozillavpn.service::https://raw.githubusercontent.com/mozilla-mobile/mozilla-vpn-client/main/linux/debian/mozillavpn.service")
+ "https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/$pkgname/$pkgver-hirsute1/${pkgname}_${pkgver}.orig.tar.gz"
+ "https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/$pkgname/$pkgver-hirsute1/${pkgname}_${pkgver}-hirsute1.debian.tar.xz")
sha256sums=('4278edc2b7fe4c19a54ea2a08272d9bb6b1e910083feb78da1d41cb76128c92f'
- 'd51c81b06f38bef502113a59930302c27652b76215a7933e3632ea16923200e3')
+ 'af3ff4ea259e8d23c040671345c323b77e352d7c3c65c4b6384ca21efae73960')
build() {
qmake PREFIX=/usr CONFIG+=production
@@ -32,7 +33,6 @@ build() {
package() {
make INSTALL_ROOT="$pkgdir" install
-
install -dm 755 "$pkgdir/usr/lib/systemd/system"
- install -Dm 644 "$pkgname.service" "$pkgdir/usr/lib/systemd/system"
+ install -Dm 644 "debian/mozillavpn.service" "$pkgdir/usr/lib/systemd/system"
}