summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavierCLL2021-11-12 19:24:45 -0800
committerXavierCLL2021-11-12 19:24:45 -0800
commitbaf020389156557b82f953393211d4ed78f0ba9d (patch)
tree9bb2c3eeb2de75da747a0c66d5a16c68e8a3adfb /PKGBUILD
parent2023e31edcd8f67ab6e34228523c466aa362d686 (diff)
downloadaur-baf020389156557b82f953393211d4ed78f0ba9d.tar.gz
v2.6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f827b76e587..6ea9ff625eca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor Tavian Barnes <tavianator@tavianator.com>
# Contributor jhorcl
pkgname=mozillavpn
-pkgver=2.5.0
-_debian_series=hirsute2
+pkgver=2.6.0
+_debian_series=impish1
pkgrel=1
pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
arch=('i686' 'x86_64')
@@ -33,19 +33,12 @@ makedepends=('qt5-tools' 'go' 'flex' 'python-yaml')
# https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+packages
source=(
"https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz"
- "https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}-${_debian_series}.debian.tar.xz"
- "libgo.patch")
-sha256sums=('2549774bd742e08cdbe2177fe43f2ce514f2dd102b1c6f68e587ce1fdbc7a71a'
- '7a76fc487168bfde3b31361f380ca93feb59517e8f31c8153fa7fb67cfe37719'
- '3c5b7047481922a1b5c6673ae78750d1af8e9dbde85632804356c829dadfa301')
+ "https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}-${_debian_series}.debian.tar.xz")
+sha256sums=('17dd9ef06a266325d2ecaf830548a002de4f5ba32ad43ebc4df6e0daa5914a3f'
+ 'e124de5757d5118d26b3b40c400b586943fc0ad8cdfe45713fc01e389c4d89e6')
build() {
cd "${pkgname}-${pkgver}"
-
- # https://github.com/mozilla-mobile/mozilla-vpn-client/pull/1490
- # https://github.com/mozilla-mobile/mozilla-vpn-client/issues/1814
- patch -Np1 -i "${srcdir}/libgo.patch" src/src.pro
-
qmake PREFIX=/usr CONFIG+=production
python scripts/importLanguages.py
make