summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavier C. Llano2022-12-15 18:23:36 -0800
committerXavier C. Llano2022-12-15 18:23:36 -0800
commite53cad1b0e3f7e7e6a6dbd8e397f58e814395db6 (patch)
tree856d1bcccf8aa3ca14563017aae00374a26c2e01 /PKGBUILD
parent0f5fefa23942bfcbfecd1ed420107ff25ccad85f (diff)
downloadaur-e53cad1b0e3f7e7e6a6dbd8e397f58e814395db6.tar.gz
v2.12.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1adab096b13..371f343be50c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: jhorcl
# Contributor: flbzh <frederic_lebouc (a) yahoo.fr>
pkgname=mozillavpn
-pkgver=2.11.0
+pkgver=2.12.0
_debian_series=kinetic1
pkgrel=1
pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
@@ -32,17 +32,13 @@ depends=('polkit'
'openresolv')
makedepends=('cmake' 'qt6-tools' 'go' 'flex' 'python-yaml' 'python-lxml' 'clang' 'cargo')
# https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+packages
-source=("https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz" "issue_6676.patch")
-sha256sums=('9f26fd7da7e486798fafa01657d346d163534edbb33e5096aef4559d5dd6959f'
- '1d2dc2b0be6e482aaf2eb820024f53634395d1d94e0eb3add81cdc0e64dc5152')
+source=("https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz")
+sha256sums=('0d7143c07495601c90ca1c94c151c9b5b16921e1c8e3a64abad18d91db6bea29')
build() {
cd "${pkgname}-${pkgver}"
rm -rf build && mkdir build && cmake -S . -B build -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
-
- # fix compiling with Qt >= 6.4
- patch -p0 < ../issue_6676.patch
-
+
cmake --build build -j6
}