summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavierCLL2022-03-14 12:03:04 -0700
committerXavierCLL2022-03-14 12:03:04 -0700
commitefdc885d9f0e5fb55144ed9058c8525a8df9a379 (patch)
treeb9104baafe9e099b8c3f8739249ccd3de61fa792 /PKGBUILD
parenta7875ba234ea366f35d1ff7ef77890c687d1003f (diff)
downloadaur-efdc885d9f0e5fb55144ed9058c8525a8df9a379.tar.gz
temporally building as debug mode with some flags while the issue is fixed, thanks to flbzh
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d043ac94822b..8f1677acda35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: XavierCLL <xavier.corredor.llano (a) gmail.com>
-# Contributor Tavian Barnes <tavianator@tavianator.com>
-# Contributor jhorcl
+# Contributor: Tavian Barnes <tavianator@tavianator.com>
+# Contributor: jhorcl
+# Contributor: flbzh <frederic_lebouc (a) yahoo.fr>
pkgname=mozillavpn
pkgver=2.7.0
_debian_series=impish1
@@ -39,9 +40,12 @@ sha256sums=('0aca5cc0752d30b7b120d8cf277cac6ef4e085db5f9d68fec3450030b0b1215b'
build() {
cd "${pkgname}-${pkgver}"
- qmake PREFIX=/usr CONFIG+=production
python scripts/importLanguages.py
- make
+ qmake PREFIX=/usr CONFIG+=debug \
+ QMAKE_LFLAGS='-Wl,--sort-common,--as-needed,-z,relro,-z,now -pipe -march=x86-64 -mtune=generic -pipe -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security -fstack-clash-protection -fcf-protection -Wp,-D_GLIBCXX_ASSERTIONS -std=gnu++1z -pthread -flto=4 -fno-fat-lto-objects -fuse-linker-plugin -fPIC' \
+ QMAKE_CFLAGS='-pipe -march=x86-64 -mtune=generic -fno-plt -fexceptions -Wformat -Werror=format-security -fstack-clash-protection -fcf-protection -pthread -Wall -Wextra -D_REENTRANT -fPIC $(DEFINES)' \
+ QMAKE_CXXFLAGS='-pipe -march=x86-64 -mtune=generic -fno-plt -fexceptions -Wformat -Werror=format-security -fstack-clash-protection -fcf-protection -Wp,-D_GLIBCXX_ASSERTIONS -std=gnu++1z -pthread -Wall -Wextra -D_REENTRANT -fPIC $(DEFINES)'
+ make all
}
package() {