summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavierCLL2021-06-16 18:57:51 -0700
committerXavierCLL2021-06-16 18:57:51 -0700
commitf89359a278e6bee6722b5c0976c9ecf2a2374758 (patch)
tree3e5ea1d76b3b50fda2a4e2dbb65ced076f166945 /PKGBUILD
parent027261afa15b57bf2d1d36d3ed80aaeb6f812a5c (diff)
downloadaur-f89359a278e6bee6722b5c0976c9ecf2a2374758.tar.gz
Cleaning up
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 4 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7aba1c6ea557..1814725f14b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,10 @@
pkgname=mozillavpn
pkgver=2.3.1
pkgrel=1
-epoch=
pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
arch=('i686' 'x86_64')
url="https://vpn.mozilla.org/"
license=('GPL')
-groups=()
depends=('polkit'
'qt5-charts'
'qt5-declarative'
@@ -21,29 +19,18 @@ depends=('polkit'
'wireguard-tools'
'WIREGUARD-MODULE')
makedepends=('qt5-tools')
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=('mozilla-vpn-client')
-replaces=('mozilla-vpn-client')
-backup=()
-options=()
-install=
-changelog=
source=("https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/$pkgname/$pkgver-groovy1/${pkgname}_${pkgver}.orig.tar.gz" "$pkgname.service")
-noextract=()
sha256sums=('4278edc2b7fe4c19a54ea2a08272d9bb6b1e910083feb78da1d41cb76128c92f'
'cedcbee738273d11d597a3054a55da98fa45daa0c58cd70936be54f0eae956a4')
-validpgpkeys=()
build() {
qmake PREFIX=/usr CONFIG+=production
- make
+ make
}
package() {
- make INSTALL_ROOT="$pkgdir" install
-
- install -dm 755 "$pkgdir/usr/lib/systemd/system"
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -dm 755 "$pkgdir/usr/lib/systemd/system"
install -Dm 644 "$pkgname.service" "$pkgdir/usr/lib/systemd/system"
}