summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavierCLL2022-07-27 12:28:33 -0700
committerXavierCLL2022-07-27 12:28:33 -0700
commitf8c9fa478ae04b3cce783e63aab3b1b947d0560f (patch)
tree0895755f42a45651aa82d6bb164bf95413a5f2f5 /PKGBUILD
parent694b6be87c51f689a105d8b4c8e4f6c23863079a (diff)
downloadaur-f8c9fa478ae04b3cce783e63aab3b1b947d0560f.tar.gz
2.9.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 7 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17a0ab83c8d0..1b0d913be83d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: jhorcl
# Contributor: flbzh <frederic_lebouc (a) yahoo.fr>
pkgname=mozillavpn
-pkgver=2.8.0
+pkgver=2.9.0
_debian_series=jammy1
pkgrel=1
pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
@@ -29,25 +29,18 @@ depends=('polkit'
'wireguard-tools'
'WIREGUARD-MODULE'
'openresolv')
-makedepends=('qt6-tools' 'go' 'flex' 'python-yaml' 'clang' 'cargo')
+makedepends=('cmake' 'qt6-tools' 'go' 'flex' 'python-yaml' 'clang' 'cargo')
# https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+packages
-source=(
- "https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz"
- "https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}-${_debian_series}.debian.tar.xz")
-sha256sums=('4d6d1cf92ce330c705d7acafe8fbef45711878fb1a65ea846f5a4b7f3e9d013f'
- 'b17bbccaa998806789bd08fc7bba5c1e10b31a4315e7cdbb2145f4929a8461e1')
+source=("https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz")
+sha256sums=('122b2e465da3dcbb226bde38413e7969b6128553999b1fc1ad59e1e3ace311ff')
build() {
cd "${pkgname}-${pkgver}"
- export PATH=/usr/lib/qt6/bin/:$PATH
- python scripts/utils/import_languages.py
- qmake6 PREFIX=/usr CONFIG-=debug CONFIG+=release CONFIG-=debug_and_release CONFIG+=webextension
- make
+ rm -rf build && mkdir build && cmake -S . -B build -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
}
package() {
cd "${pkgname}-${pkgver}"
- make INSTALL_ROOT="$pkgdir" install
- install -dm 755 "$pkgdir/usr/lib/systemd/system"
- install -Dm 644 "linux/mozillavpn.service" "$pkgdir/usr/lib/systemd/system"
+ DESTDIR="$pkgdir" cmake --install build
}