summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Laß2023-06-18 11:04:24 +0200
committerMichael Laß2023-06-18 11:04:24 +0200
commitd898f20d8a59b9600316d876981035ee2f48d21b (patch)
tree4b410aa1d4d7ac3a395082404cb7e3e3f5683a64 /PKGBUILD
parent754ba94bc77143703b3a73e0cfc4026b216db594 (diff)
downloadaur-d898f20d8a59b9600316d876981035ee2f48d21b.tar.gz
Update to 2.1.0 and make it build against Qt 6.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 7 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d73fb3ee8542..b13fc3dd6c87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=mp-sonivoxeas
_pkgname=multiplatform-sonivoxeas
-pkgver=2.0.0
+pkgver=2.1.0
pkgrel=1
pkgdesc="Multiplatform Sonivox EAS for Qt"
arch=(x86_64)
@@ -14,25 +14,17 @@ license=('GPL3')
depends=(drumstick qt6-multimedia sonivox)
makedepends=(cmake)
source=("https://github.com/pedrolcl/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('46b27083e92b5e6759b7ba3284a513069f6987ddfa2e07619dfeb1635e28e532')
+sha256sums=('91cfb33602c833d366b3e51bf00d15bd69d719d397a20a1109aeff2f6422e0e8')
-prepare() {
- cd "$_pkgname-$pkgver"
-
- # Do not build against Qt5 because Drumstick is built against Qt6
- sed -i 's/Qt5 //g' CMakeLists.txt
+build() {
- # Fix icon installation target (from 0699cdc70d25d10ccfe6aa9269333f6a374b9d7b)
- sed -i 's#icons/hicolor/128x128#icons/hicolor/128x128/apps#g' guisynth/CMakeLists.txt
+ # https://github.com/pedrolcl/drumstick/issues/12
+ export CXXFLAGS+=" -D DRUMSTICK_EXPORT=\"__attribute__((visibility(\\\"default\\\")))\""
- # Let WMs recognize mp_guisynth windows
- echo "StartupWMClass=mp_GUISynth" >> guisynth/mp_guisynth.desktop
-}
-
-build() {
cmake -B build -S "$_pkgname-$pkgver" \
-DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_QT=6
cmake --build build
}