summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2009-08-12 22:17:38 -0400
commit2136ee8b0313cda9f5da2fcd1d0977885bce7f6e (patch)
tree84becd32deb031c229e5776c618e3a7928bd3f99 /PKGBUILD
downloadaur-2136ee8b0313cda9f5da2fcd1d0977885bce7f6e.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4eb8d301138
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+
+pkgname=mpc-git
+pkgver=20090509
+pkgrel=1
+pkgdesc="A minimalist command line interface to MPD"
+arch=('i686' 'x86_64')
+url="http://mpd.wikia.com"
+license=('GPL2')
+depends=('glibc')
+makedepends=('git')
+optdepends=('bash-completion')
+conflicts=('mpc')
+provides=('mpc')
+replaces=('mpc-svn')
+source=()
+md5sums=()
+
+_gitroot="git://git.musicpd.org/master/mpc.git"
+_gitname="mpc"
+
+build() {
+ cd ${srcdir}
+
+ msg "Connecting to GIT server..."
+
+ if [ -d ${srcdir}/$_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ # Copy Latest files to Build Directory
+ rm -rf ${srcdir}/$_gitname-build
+ git clone ${srcdir}/$_gitname ${srcdir}/$_gitname-build
+ cd ${srcdir}/$_gitname-build
+
+ # Configure Source
+ ./autogen.sh --prefix=/usr
+
+ # Build Source
+ make || return 1
+
+ # Install Source
+ make prefix=${pkgdir}/usr install || return 1
+
+ # Install Bash Completion File
+ install -D -m 644 ${srcdir}/$_gitname/doc/mpc-bashrc \
+ ${pkgdir}/etc/bash_completion.d/mpc
+}
+