summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKenjiTakahashi2019-03-10 13:16:02 +0100
committerKenjiTakahashi2019-03-10 13:16:02 +0100
commit35cebd2dc1f0a658b30f4cda39cf96800c5081d5 (patch)
tree3e4dfcfb3fabcde4cfbfa96b2bc8cf29a9629b05 /PKGBUILD
parentf19e61ce9c99fe005fb85a9115dbe5d9a7d0b0f4 (diff)
downloadaur-35cebd2dc1f0a658b30f4cda39cf96800c5081d5.tar.gz
0.21.5-1: Bumped version
Change to new build system.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD83
1 files changed, 50 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00fb5aa85dcd..cb051f437187 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
# Contributor: Ben <ben@benmazer.net>
pkgname=mpd-light-pulse
-pkgver=0.20.20
-_majorver=0.20
+pkgver=0.21.5
+_majorver=0.21
pkgrel=1
pkgdesc='Flexible, powerful, server-side application for playing music. Light version without libmpdclient, openal, ao, ffmpeg, jack, modplug, shout, sidplay, soundcloud, wavpack, fluidsynth, avahi, smbclient, zziplib support.'
url='https://www.musicpd.org/'
@@ -16,56 +16,73 @@ license=('GPL')
arch=('i686' 'x86_64' 'armv6h')
depends=('audiofile' 'libmad' 'curl' 'faad2' 'sqlite' 'libmms' 'libid3tag' 'libpulse'
'icu' 'libupnp' 'libnfs' 'libsamplerate' 'libsoxr' 'libcdio-paranoia' 'libgme')
-makedepends=('doxygen' 'boost')
+makedepends=('boost' 'meson' 'python-sphinx')
provides=("mpd=$pkgver")
conflicts=('mpd')
replaces=('mpd')
source=("https://www.musicpd.org/download/mpd/${_majorver}/mpd-${pkgver}.tar.xz"
'mpd.tmpfile'
'mpd.conf')
-sha256sums=('a9e458c6e07cdf62649de7722e1e5a7f13aa82eeb397bfbbebc07cf5cf273584'
+sha256sums=('2ea9f0eb3a7bdae5d705adf4e8ec45ef38b5b9ddf133f32b8926dd4e205b0ef9'
'c1683ba35774c85e16c70e89f7e2ed1c09619512b1a273daabbd5e34d40439bd'
'e213c108cd0e076b5cc07091707ef75d74d9ac8c779d0c0128cd0aa69617f8a0')
backup=('etc/mpd.conf')
install=mpd.install
-build() {
+prepare() {
cd "${srcdir}/mpd-${pkgver}"
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --enable-cdio-paranoia \
- --disable-libmpdclient \
- --disable-openal \
- --enable-pulse \
- --disable-ao \
- --disable-ffmpeg \
- --disable-jack \
- --disable-modplug \
- --disable-shout \
- --disable-sidplay \
- --disable-soundcloud \
- --disable-wavpack \
- --disable-zzip \
- --with-zeroconf=no \
- --disable-smbclient \
- --disable-fluidsynth \
- --with-systemdsystemunitdir=/usr/lib/systemd/system
+ rm -fr build
+ install -d build
+}
+
+build() {
+ cd "${srcdir}/mpd-${pkgver}/build"
- make
+ _opts=('-Ddocumentation=true'
+ '-Dchromaprint=disabled' # appears not to be used for anything
+ '-Dsidplay=disabled' # unclear why but disabled in the past
+ '-Dlibwrap=disabled' # twentieth century's over
+ '-Dadplug=disabled' # not in an official repo
+ '-Dsndio=disabled' # interferes with detection of alsa devices
+ '-Dshine=disabled' # not in an official repo
+ '-Dao=disabled'
+ '-Dffmpeg=disabled'
+ '-Djack=disabled'
+ '-Dmodplug=disabled'
+ '-Dshout=disabled'
+ '-Dsidplay=disabled'
+ '-Dsoundcloud=disabled'
+ '-Dwavpack=disabled'
+ '-Dzzip=disabled'
+ '-Dzeroconf=disabled'
+ '-Dsmbclient=disabled'
+ '-Dlibmpdclient=disabled'
+ '-Dopenal=disabled'
+ '-Dfluidsynth=disabled'
+ )
+ arch-meson --auto-features auto .. ${_opts[@]}
+ ninja
}
package() {
- cd "${srcdir}/mpd-${pkgver}"
+ cd "${srcdir}/mpd-${pkgver}/build"
+
+ DESTDIR="${pkgdir}" ninja install
- make DESTDIR="${pkgdir}" install
+ install -Dm644 ../doc/mpdconf.example "${pkgdir}"/usr/share/doc/mpd/mpdconf.example
+ install -Dm644 ../doc/mpd.conf.5 "${pkgdir}"/usr/share/man/man5/mpd.conf.5
+ install -Dm644 ../doc/mpd.1 "${pkgdir}"/usr/share/man/man1/mpd.1
- install -Dm644 ../mpd.conf "${pkgdir}"/etc/mpd.conf
- install -Dm644 ../mpd.tmpfile "${pkgdir}"/usr/lib/tmpfiles.d/mpd.conf
+ install -Dm644 "${srcdir}"/mpd.conf "${pkgdir}"/etc/mpd.conf
+ install -Dm644 "${srcdir}"/mpd.tmpfile "${pkgdir}"/usr/lib/tmpfiles.d/mpd.conf
install -d -g 45 -o 45 "${pkgdir}"/var/lib/mpd{,/playlists}
- install -Dm644 "${pkgdir}"/usr/lib/systemd/{system,user}/mpd.service
- sed '/\[Service\]/a User=mpd' -i "${pkgdir}"/usr/lib/systemd/system/mpd.service
- sed '/WantedBy=/c WantedBy=default.target' -i "${pkgdir}"/usr/lib/systemd/{system,user}/mpd.service
+ # Now service file installs only when libsystemd package was found
+ if [ -e "${pkgdir}"/usr/lib/systemd/system/mpd.service ]; then
+ sed \
+ -e '/\[Service\]/a User=mpd' \
+ -e '/WantedBy=/c WantedBy=default.target' \
+ -i "${pkgdir}"/usr/lib/systemd/system/mpd.service
+ fi
}