summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Birukov2020-11-14 00:58:45 +0300
committerAnton Birukov2020-11-14 00:58:45 +0300
commit32a9b25510e13260766e026c06dc29159e2e9292 (patch)
treef1cd6ffd3d9f8056bd1ab5eb8a23f0b43efc15a2 /PKGBUILD
parent3b28d7727398827f125f4706b8eb50d8f8714e12 (diff)
downloadaur-32a9b25510e13260766e026c06dc29159e2e9292.tar.gz
Updated to version 0.22.1 from GIT. Fixed compilation errors.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1be8e9f6a46d..672fb1ace2f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Melvin Vermeeren <mail@mel.vin>
pkgname=mpd-sacd
-pkgver=0.22.0
-pkgrel=4
+pkgver=0.22.1
+pkgrel=1
pkgdesc='MPD with patches for SACD and DVDA ISO playback.'
url='https://sourceforge.net/p/sacddecoder/mpd/MPD.git/ci/master/tree/'
license=('GPL')
@@ -10,11 +10,11 @@ arch=('i686' 'x86_64' 'aarch64' 'armv7h')
depends=('libao' 'ffmpeg' 'libmodplug' 'audiofile' 'libshout' 'libmad' 'curl' 'faad2'
'sqlite' 'jack' 'libmms' 'wavpack' 'avahi' 'libid3tag' 'yajl' 'libmpdclient'
'icu' 'libupnp' 'libnfs' 'libsamplerate' 'libsoxr' 'smbclient' 'libcdio-paranoia'
- 'libgme' 'zziplib')
-makedepends=('boost' 'meson' 'python-sphinx')
+ 'libgme' 'zziplib' 'fluidsynth' 'libmikmod' 'wildmidi')
+makedepends=('boost' 'meson' 'python-sphinx' 'clang' 'ninja')
conflicts=('mpd')
provides=("mpd=${pkgver}")
-source=('mpd::git+https://git.code.sf.net/p/sacddecoder/mpd/MPD.git#commit=3a0c90a1155ecfd2eb57e172818153c1c95ec363'
+source=('mpd::git+https://git.code.sf.net/p/sacddecoder/mpd/MPD.git#commit=ed387398fa3287d840da791005ec8dad9a81cc7d'
'sysusers.d'
'tmpfiles.d'
'conf')
@@ -32,7 +32,7 @@ prepare() {
build() {
cd "${srcdir}/mpd/build"
- _opts=('-Ddocumentation=true'
+ _opts=('-Ddocumentation=enabled'
'-Dchromaprint=disabled' # appears not to be used for anything
'-Dsidplay=disabled' # unclear why but disabled in the past
'-Dadplug=disabled' # not in an official repo
@@ -50,7 +50,7 @@ build() {
'-Dsacdiso=true'
'-Ddvdaiso=true'
)
- arch-meson .. ${_opts[@]}
+ env CC=clang CXX=clang++ arch-meson .. ${_opts[@]}
ninja
}
@@ -58,8 +58,8 @@ package() {
cd "${srcdir}/mpd/build"
DESTDIR="${pkgdir}" ninja install
install -Dm644 ../doc/mpdconf.example "${pkgdir}"/usr/share/doc/mpd/mpdconf.example
- install -Dm644 ../doc/mpd.conf.5 "${pkgdir}"/usr/share/man/man5/mpd.conf.5
- install -Dm644 ../doc/mpd.1 "${pkgdir}"/usr/share/man/man1/mpd.1
+ install -Dm644 doc/mpd.conf.5 "${pkgdir}"/usr/share/man/man5/mpd.conf.5
+ install -Dm644 doc/mpd.1 "${pkgdir}"/usr/share/man/man1/mpd.1
install -Dm644 ../../sysusers.d "${pkgdir}"/usr/lib/sysusers.d/mpd.conf
install -Dm644 ../../conf "${pkgdir}"/etc/mpd.conf