summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBruno Pagani2021-10-19 15:38:01 +0400
committerBruno Pagani2021-10-19 15:38:01 +0400
commit0a84425747147ed88367c95b7d13a0a04527f6c5 (patch)
treecf43dca25e1359e219b69cfe2f47d1bb33d6f50b /PKGBUILD
parent65aa251f6c3b7caf4c122d8e2ec0c8ce483e40a5 (diff)
downloadaur-0a84425747147ed88367c95b7d13a0a04527f6c5.tar.gz
upgpkg: mpd-server-minimal 0.23.1-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1318ea32c05..ad3e6a48c397 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
_pkgname=mpd
pkgname=${_pkgname}-server-minimal
-pkgver=0.22.6
+pkgver=0.23.1
pkgrel=1
-pkgdesc="Flexible, powerful, server-side application for playing music. Minimal version with only flac playback as server running under mpd user."
+pkgdesc="Flexible, powerful, server-side application for playing music. Minimal version with only flac playback over alsa as server running under mpd user."
arch=(i686 x86_64 armv7h)
url="https://www.musicpd.org/"
license=(GPL)
-depends=(alsa-lib flac icu libmpdclient liburing systemd-libs zlib)
+depends=(alsa-lib flac fmt icu libmpdclient liburing systemd-libs zlib)
makedepends=(boost meson python-sphinx systemd)
provides=("${_pkgname}=${pkgver}")
conflicts=(${_pkgname})
@@ -17,12 +17,12 @@ source=("${url}/download/${_pkgname}/${pkgver:0:4}/${_pkgname}-${pkgver}.tar.xz"
${_pkgname}.tmpfiles
${_pkgname}.sysusers
${_pkgname}.conf)
-sha512sums=(5e417204e24d11fa609740ae92bc1d796aad2d63537655f655074d829cd79cadaf1ca025171dcf5486c1e557cc946152c21e299286b1cb74cc342da2b1f41343
+sha512sums=(98af165881ee85c65ffd22bea77e0a62e13a8a5e8e30dc620761fe51422b605d886a957faf441bfe8f5e0728d651202c7f43e270335337a822258fcb5cd76e9e
SKIP
a2c1840bfaa96d0d21f66faa754404b3b0e63d032106e518e5e8276b3a19a7e3cf0fe6ea38471b6c02c0aea602aee8cee40b40231581de1256f7577461598012
d6f36996089cbe746f7d7062e12723d8a41a0118da9301c053e4c244221d7a32b2b0c3d64b604714243be50a98dde00f2513680dc43fc6ac12622200fc234f73
25a823740d92da8e186916701413114142eb6ad91a172c592e68b569c8e4f50fa99580e555ccf6cd31fc4f55a09bfe0278efa46e4e76ee0fe02846292fadf3c1)
-b2sums=(675b876415a343ba387e26ad800b2e562b40a5e3aaacdff31e0ec9d6ad09f0117406f82e519a08ba3187020b482dcd0434267f9e84dd13e9e1bf8565d1967c2c
+b2sums=(7b517d72c536496c4ceb579fcce3d4822a45a9975c7f1f53ab3c6e1eb1b133364eea9d62fa4ef53065961e3edf4474ba454aac846d50c5a96428cbacacdb0d9d
SKIP
efe312e269f30ff1413c43c5ff712548f58a8099b32f4a709b8441d1e58444c2e8306d041f4e8d355a06ea5b1c86f4985b531cc17f2e7d83d0fd514f59a1b853
97e7d992a0c347fa6f34464136e5b603bdf50eb4a4718504c951ab9ef34d17f0f7b9f917974d049b88e54185dce2f64eb0e59fd40aa921b11d9703219809c29e
@@ -63,7 +63,6 @@ build() {
'-Dsmbclient=disabled'
'-Dqobuz=disabled'
'-Dsoundcloud=disabled'
- '-Dtidal=disabled'
'-Dbzip2=disabled'
'-Diso9660=disabled'
'-Dzzip=disabled'
@@ -79,6 +78,7 @@ build() {
'-Dmad=disabled'
'-Dmikmod=disabled'
'-Dmodplug=disabled'
+ '-Dopenmpt=disabled'
'-Dmpcdec=disabled'
'-Dmpg123=disabled'
'-Dopus=disabled'
@@ -103,9 +103,11 @@ build() {
'-Dopenal=disabled'
'-Doss=disabled'
'-Dpipe=false'
+ '-Dpipewire=disabled'
'-Dpulse=disabled'
'-Drecorder=false'
'-Dshout=disabled'
+ '-Dsnapcast=false'
'-Dsndio=disabled'
'-Dsolaris_output=disabled'
'-Ddbus=disabled'
@@ -119,7 +121,7 @@ build() {
'-Dzeroconf=disabled'
)
- arch-meson ${_opts[@]} build
+ arch-meson ${_opts[@]} -D b_ndebug=true build
ninja -C build
}