summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhxss2020-12-06 14:37:41 +0300
committerhxss2020-12-06 14:37:41 +0300
commit64a297ea8786ed8478e1205b652cbc4389ca1b09 (patch)
tree58ed5b4ba9f7efba117b477954d25db8e4242e69 /PKGBUILD
downloadaur-64a297ea8786ed8478e1205b652cbc4389ca1b09.tar.gz
init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b1dd2dd411b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Sergey Khobta <hxss@ya.ru>
+
+pipname=mpris-fakeplayer
+pkgname=$pipname
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Fake mpris player for activating bluez avrcp volume control'
+arch=(any)
+url='https://gitlab.com/hxss-linux/mpris-fakeplayer'
+license=(MIT)
+depends=('python')
+optdepends=('python-systemd: systemd logging')
+makedepends=('python-pip' 'curl' 'jq' 'findutils')
+install='INSTALL'
+
+pkgver() {
+ curl -s https://pypi.org/pypi/$pipname/json | jq -r .info.version
+}
+
+package() {
+ PIP_CONFIG_FILE=/dev/null pip install $pipname \
+ --root=$pkgdir \
+ --isolated \
+ --no-user \
+ --no-deps \
+ --ignore-installed \
+ --quiet
+
+ python -O -m compileall "$pkgdir"
+
+ install -Dm644 $(find $pkgdir -name LICENSE*) \
+ -t "$pkgdir/usr/share/licenses/$pkgname"
+}