summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Kobel2016-02-13 02:03:55 +0100
committerAlexander Kobel2016-02-13 02:04:00 +0100
commit050b2f32e91a12497418e757a59db53082136029 (patch)
tree31fb668942f587410555a78bd5a1114ff9061633 /PKGBUILD
parente76f0b35491cd2bbcf76260baf986c6a6d32f931 (diff)
downloadaur-050b2f32e91a12497418e757a59db53082136029.tar.gz
Update to 3.1.4-4
fix PKGBUILD if octave bindings are not built
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6308e8ef641b..6661f010a640 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mpsolve-git
pkgver=3.1.4.r335.ga468e63
-pkgrel=3
+pkgrel=4
pkgdesc="Multiprecision rootfinder for complex roots of univariate polynomials"
url="http://numpi.dm.unipi.it/software/mpsolve"
arch=('i686' 'x86_64')
@@ -38,5 +38,7 @@ check () {
package () {
cd ${srcdir}/MPSolve
make DESTDIR="${pkgdir}" install
- sed -e "s/$(echo "${pkgdir}" | sed -e 's/[\/&]/\\&/g')//g" -i ${pkgdir}/usr/share/octave/octave_packages
+ if [ -f ${pkgdir}/usr/share/octave/octave_packages ]; then
+ sed -e "s/$(echo "${pkgdir}" | sed -e 's/[\/&]/\\&/g')//g" -i ${pkgdir}/usr/share/octave/octave_packages
+ fi
}