summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorInochi Amaoto2020-11-27 09:19:48 +0800
committerInochi Amaoto2020-11-27 09:19:48 +0800
commit07044e6f28c2f97c5808524078afbd5045a65835 (patch)
treeba1a2a6f13b7d7c0349ff4bd1a1225bfe0c7cbc5 /PKGBUILD
parent1e3bcc0bf8bf85db6c89aac03b5820cd28ed1277 (diff)
downloadaur-07044e6f28c2f97c5808524078afbd5045a65835.tar.gz
Add sixel support, update version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb47d297c33d..9b2e1571e5a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Inochi Amaoto <libraryindexsky@gmail.com>
pkgname=mpv-full-build-git
-pkgver=0.32.0.r810.gf85de9e6d6
+pkgver=0.33.0.r5.g62fb374349
pkgrel=1
pkgdesc="Video player based on MPlayer/mplayer2 with all possible libs (uses statically linked ffmpeg with all possible libs). (GIT version )"
arch=('x86_64')
@@ -130,6 +130,7 @@ optdepends=(
'libilbc: Additional libilbc support for ffmpeg'
'libklvanc-git: Additional libklvanc support for ffmpeg'
'libopenmpt: Additional libopenmpt support for ffmpeg'
+ 'libsixel: Allow mpv to implement sixel as a output device'
'kvazaar: Additional libkvazaar support for ffmpeg'
'mpv-bash-completion-git: Additional completion definitions for Bash users'
'nvidia-utils: for hardware accelerated video decoding with CUDA'
@@ -195,6 +196,9 @@ if [ -z ${MPV_NO_CHECK_OPT_DEPEND+yes} ]; then
if [ -f /usr/lib/libshine.so ]; then
depends+=('shine')
fi
+ if [ -f /usr/lib/libsixel.so ]; then
+ depends+=('libsixel')
+ fi
if [ -f /usr/lib/libtensorflow.so ]; then
depends+=('tensorflow')
fi
@@ -411,6 +415,9 @@ prepare() {
if [ -f /usr/lib/libshine.so ]; then
_ffmpeg_options+=('--enable-libvo-amrwbenc')
fi
+ if [ -f /usr/lib/libsixel.so ]; then
+ _mpv_options+=('--enable-sixel')
+ fi
if [ -f /usr/lib/libtensorflow.so ]; then
_ffmpeg_options+=('--enable-libtensorflow')
_ffmpeg_options+=('--extra-cflags=-I/usr/include/tensorflow')