summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorInochi Amaoto2022-09-30 09:22:02 +0800
committerInochi Amaoto2022-09-30 09:22:02 +0800
commit9ded8e7de1f34010e8827eba483cc3c8f511d63b (patch)
tree11e4cfaa312074e3870753937715737656263524 /PKGBUILD
parent94ebb9535038820b1c6f16a4206bbca04b4c8f07 (diff)
downloadaur-9ded8e7de1f34010e8827eba483cc3c8f511d63b.tar.gz
add libass options to restrict build autodetect
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 191a14e69aa8..dd2b131c93be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Inochi Amaoto <libraryindexsky@gmail.com>
pkgname=mpv-full-build-git
-pkgver=0.34.0.r441.g9be52e5dd8
+pkgver=0.34.0.r493.g98e6fb26a3
pkgrel=1
pkgdesc="Video player based on MPlayer/mplayer2 with all possible libs (uses statically linked ffmpeg with all possible libs). (GIT version )"
arch=('x86_64')
@@ -24,6 +24,7 @@ depends=(
'gnutls'
'gsm'
'glslang'
+ 'harfbuzz'
'hicolor-icon-theme'
'jack'
'kvazaar'
@@ -416,6 +417,10 @@ prepare() {
'--enable-zimg'
'--enable-zlib'
)
+ _libass_options=(
+ '--enable-harfbuzz'
+ '--enable-fontconfig'
+ )
local _legacy_mpv_options=(
'--enable-gl-x11'
@@ -482,6 +487,7 @@ prepare() {
(IFS=$'\n'; echo "${_ffmpeg_options[*]}" > ffmpeg_options)
(IFS=$'\n'; echo "${_mpv_options[*]}" > mpv_options)
+ (IFS=$'\n'; echo "${_libass_options[*]}" > libass_options)
cd mpv