summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-04-16 17:04:41 +0000
committerDaniel Bermond2018-04-16 17:19:10 +0000
commit1008b03fb0c5edd2c32087d91271d9aaeb97d330 (patch)
tree83dfcf4af5de149550ef83f5fb2661950c8bb5a5 /PKGBUILD
parent1143654ebdff39d3574a077db3ae7f95e5a830fe (diff)
downloadaur-1008b03fb0c5edd2c32087d91271d9aaeb97d330.tar.gz
makedepends: add ffnvcodec-headers (now needed by cuda-hwaccel)
Also on this commit: -------------------- - depends: moved 'sndio' from the AUR section to the official repositories section (it is now on the [community] official repository References: ----------- https://github.com/mpv-player/mpv/commit/07915b12273a36bc7f104a5f3fc949a407d243dc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80bf50bd0569..8d7e004d4d2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=mpv-full-git
-pkgver=0.28.2.r374.g12b90e744d
-pkgrel=2
+pkgver=0.28.2.r451.gc647516278
+pkgrel=1
pkgdesc='A free, open source, and cross-platform media player (git version with all possible libs)'
arch=('i686' 'x86_64')
license=('GPL3')
@@ -12,17 +12,21 @@ depends=(
'lcms2' 'libcdio-paranoia' 'libgl' 'libxss'
'libxinerama' 'libxv' 'libxkbcommon' 'libva' 'wayland' 'libcaca'
'desktop-file-utils' 'hicolor-icon-theme' 'xdg-utils' 'lua52' 'libdvdnav'
- 'libxrandr' 'jack' 'rubberband' 'uchardet' 'libarchive'
- 'openal' 'smbclient' 'vulkan-icd-loader' 'zlib'
+ 'libxrandr' 'jack' 'rubberband' 'uchardet' 'libarchive' 'smbclient'
+ 'zlib' 'sndio' 'openal' 'vulkan-icd-loader'
# AUR:
- 'ffmpeg-git' 'mujs' 'rsound' 'sndio' 'shaderc-git' 'crossc'
- 'vapoursynth-git'
+ 'ffmpeg-git' 'mujs' 'rsound' 'shaderc-git' 'crossc' 'vapoursynth-git'
)
optdepends=('youtube-dl: for video-sharing websites playback'
'nvidia-utils: for hardware accelerated video decoding with CUDA')
-makedepends=('git' 'mesa' 'python-docutils' 'ladspa' 'vulkan-headers'
- 'wayland-protocols')
+makedepends=(
+ # official repositories:
+ 'git' 'mesa' 'python-docutils' 'ladspa' 'vulkan-headers'
+ 'wayland-protocols'
+ # AUR:
+ 'ffnvcodec-headers'
+)
provides=('mpv')
conflicts=('mpv' 'mpv-git')
options=('!emptydirs')